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About OnTheAir Video 4  

OnTheAir Video (OTAV) is a macOS application that allows you to broadcast almost any 
video clip that can be exported directly from Final Cut Pro or any other editing software. It 
can be used by television stations, large or small, network or closed circuit, to broadcast 
programs or as video player for news or live television programming.  OnTheAir Video is 
also intended to be used for live performances, shows, exhibitions, trade shows, information 
kiosks, etc.  Its use is solely limited by the imagination.  

Simplicity  
The User Interface has been designed to be easy to use. It is the key of OnTheAir Video’s 
success.  

Flexibility 
OnTheAir Video is also very flexible, it supports multiple formats (HD, 4K or 8K) and a wide 
range of codecs. It means it integrates easily with past, present and future systems. Receive 
a file from a production facility, drag and drop to your playlist your file is ready to be aired 
without having to compress it or convert it. 
OnTheAir Video does not require any proprietary hardware either. Almost any recent Mac 
can be used. Add a video card (PCIe or Thunderbolt) or output to NDI and start 
broadcasting. It is also easily integrated into traffic or automation systems.  

Security 
OnTheAir Video is based on a macOS architecture which is known for reliability and 
flexibility. All solutions developed by Softron Media Services are fully tested and approved 
before released. Prompt and personalized support is also what we do best. 

OnTheAir Video 4 is a very intuitive program with a lot of features and functions. What 
follows is a brief explanation of how to use the application, beginning with installation 
instructions, followed by a description of the User Interface and then with instructions on 
how to get the most from the application. 

In addition to this user manual, you can also find a lot of information: 
• on our website: www.softron.tv; at the bottom of the OnTheAir Video page you will find: 

- http://softron.tv/downloads: to download the latest version of OnTheAir Video.   
- Tech Specs: where you will find recommendations on what you need, what drivers 

to use, what video cards and codecs are compatible, etc. 
• in our Release notes.  
• on our support desk, there a lot of information is available in the help center. 
• on our YouTube channel, 
• and don’t forget to follow us on Twitter and Facebook for the latest Softron news. 

 

http://www.softron.tv
https://softron.tv/products/play/ontheair-video?content=overview
https://softron.tv/products/play/ontheair-video?content=downloads
https://softron.tv/products/play/ontheair-video?content=specs
http://softron.tv/news/Release-Notes/
https://softron.zendesk.com/hc/en-us
https://www.youtube.com/user/Softronmedia


-  -5

OnTheAir Video User Manual

What’s New in OnTheAir Video 4.2 ? 

With the release of OnTheAir Video 4.2, a lot of changes were made: 

• New Actions: Previously, in OnTheAir Video 4.1 or earlier, actions were only 
AppleScripts. With version 4.2, actions can be other things than AppleScript in order 
for example to control the DGO or video routers directly. These new actions required 
us to change the playlist format to save these actions. Thus there could be issues 
when going back and forth between version 4.2 (or later) and earlier versions of 
OnTheAir Video which were using different actions. Here is the behavior to expect: 

> When going from version 4.1 to 4.2: 
Actions will be converted to the new actions with attributes, there is 
nothing to do. You can save the playlist in the new format and if you 
only use AppleScript actions, you can go back and forth between 
version 4.1 and 4.2, but not if you use other types of actions. 

> When going from version 4.2 to 4.1: 
If you were using only "AppleScript" actions in version 4.2, there will be 
no issue. If you used other types of actions, you will be able to open the 
playlist in version 4.1, but if you save your playlist in version 4.1, you will 
loose all "non-AppleScript" actions and you won't be able to retrieve 
them when reopening with version 4.2. So make sure to disable auto-
save in that case. 

• Scheduler: New "Calendar" type of user interface. 

• Added the ability to trigger an Action when a SCTE trigger is received on a video 
input. 

• Remote: Added the "Remote Pack" option with the ability to control OnTheAir Video, 
view and edit opened playlists (Using : http://127.0.0.1:8081/web_ui/index.html). 

• Traffic Option: Added support for BXF playlist format 

• REST API: Added the ability to get info and modify the currently playing clip. Added 
the ability skip to next only on live items. We recommend using the same OnTheAir 
Video versions for the client and the server. Particularly if you are using actions. 

• Added the ability to use transitions when controlling an ATEM (so select an input in 
preview, then do the "auto" transition" (only with the new actions), we also added a 
"none" to the ATEM triggers so you can connect to an ATEM (to control it using the 
new OnTheAir Video actions), but it won't trigger any playback action in OnTheAir 
Video 

• Issues with port number when using multiple remote instances on the same Mac 

… And many new features on their way !  

To see the latest news, improved features and all the details, go to our Softron website.  
If you want to submit a request, contact our support team, always ready to help you!  

 

 

https://softron.tv/support/release-notes/?category=MovieRecorder
https://softron.zendesk.com/hc/en-us/requests/new
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Main Differences between OnTheAir Video and 
OnTheAir Video Express 

Important Note: In this document, to keep things simple, we will mainly use the words 
“OnTheAir Video” and “OTAV”. We will just indicate which features are only for OnTheAir 
Video, so if you are using OnTheAir Video Express you can skip these parts. 

We offer two versions of our playout application. OnTheAir Video Express is the "entry-level" 
ingest solution from Softron, while OnTheAir Video offers more advanced features. 
You can compare the two versions in the feature list of the OnTheAir Video page on our 
website. 

Features that are only available in OnTheAir Video: 

• Built-in CG:  (Requires the Dynamic Graphics Overlay Option) Additionally to still 
images, you can now import CG Projects in OnTheAir Video to be overlaid on top of 
the video playback. 

• Transitions: You can use either built-in transitions such as cross-fades, or custom 
transitions (made with your own movies with an Alpha Channel) 

• Secondary Audio Output: Additionally to the video output on the selected video 
device, you can now also output to another available audio output on your Mac. 
Works with CoreAudio, so supports the audio devices that are available for macOS 
(including Dante or MADI). 

• Scheduler:  Prepare your playlists and schedules in advance and let OnTheAir Video 
do the rest. OnTheAir Video can play 24/7 for days and days without having to worry 
about it. 

• Remote Control (Requires the remote pack option): se a simple web browser on 
another computer, or another OnTheAir Video to control your playout remotely. 

• Traffic option: Create your playlist (or log) in your traffic solution, such as Wide Orbit, 
and OnTheAir Video will import it and play it out. The traffic option includes the 
"Remote Pack" option. 

• LIVE sources: Use NDI or any video card input as a clip in your playlist to playout live 
programs 

• Streaming input: Supports RTMP video input to play a web stream easily. Just add a 
"stream clip" to your playlist, enter the RTMP url and start playing it back. 

• Closed Captioning. (Requires the CC option). It is supported either in an MXF file 
with OP47, or using sidecar files in .SRT or .STL extension. 

• REST API:  OnTheAir Video is now coming with a full REST API that allows to control 
it remotely from a webpage 

• Actions (Secondary events) 
• Ability to control a Video router: Blackmagic-Design Videohub or a Ross video 

router without the need of OnTheAir Switch. This can be done using Actions. 
• Support for SCTE triggers. (Requires the CC option) 
• AppleScriptable. Controllable by AppleScript 

 

https://softron.tv/products/play/ontheair-video?content=features
https://softron.tv/products/play/ontheair-video?content=features
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Before the Installation 

If you use a video device from AJA, Blackmagic Design or Deltacast, make sure the device is 
physically connected. Double check that all cables and hardware are installed correctly.  

Also check that you have the appropriate version of the driver and OS: 
1. On the Softron website, check which driver and OS is recommended for your card. 
2. Download the appropriate driver from the AJA, Blackmagic-Design or Deltacast website. 
3. Make sure you use a compatible version of Mac OS 

Mac and MacOS Requirements 

OnTheAir Video 4.2 requires : 
• Computer: Mac Intel or Silicon (A graphics card that supports Metal is required for 

the SMART Resize and Graphics option) 
• MacOS: 10.15.5 or later (14.00 or later recommended) 
• Memory: Min. 4 GB RAM for Single playback (add 2GB of RAM for additional channel) 

Other requirements will depend on what you intend to do. Which format, fps, codec of video 
files you intend to play? Will you be using the DGO option. A 4 core 2018 (or later) Mac mini 
should answer most of the needs for one HD channel. More infos in our website.  

Video / Audio Output 

OnTheAir Video 4.2 also requires : 
• Video outputs:  

	 	 - A PCI card or Thunderbolt device from AJA, Blackmagic Design or Deltacast 
	 	 - NDI 
	 	 - Not possible to output with the built-in video monitor output of your Mac 

• Video inputs:  
	 	 - A PCI card or Thunderbolt device from AJA, Blackmagic Design or Deltacast 
	 	 - NDI 
	 	 - Stream (RTMP, RTSP, HTTP, HLS) 

To know which cards are supported at the time of reading, have a look at the Softron 
website on the OnTheAir Video Specifications page. 
For multichannel, you can either install multiple cards or connect multiple thunderbolt 
devices, or use a device that supports multiple channels. 

It should not be an issue to upgrade drivers of your video card. However it happens from 
time to time that some issues appear when upgrading drivers. So always do a test on 
another computer first and stay tuned with our website to be informed about possible 
issues. If you encounter any problem, contact us using the Support Contact page from the 
website. 

 

https://softron.tv/products/play/ontheair-video?content=specs
https://www.aja.com/en/support
http://www.blackmagicdesign.com/support
https://www.deltacast.tv/support
https://support.apple.com/en-us/HT205073
https://softron.tv/products/play/ontheair-video?content=specs
https://softron.tv/products/play/ontheair-video?content=specs
https://softron.tv/products/play/ontheair-video?content=specs
https://softron.tv/about/contact
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Storage 

You should be able to use any volume that will mount on your Mac to read the video with 
OnTheAir Video. But of course you need to check that the data rate is sustained considering 
the codec and file format you are using.  
You can use OnTheAir Video with the internal disks of your Mac. But if you are working with 
a large number of files or with High Definition files, we recommend you work with Fibre. 
 

Supported Codecs - File Formats 

 



-  -9

OnTheAir Video User Manual

About VANCs 

Some additional information can be encoded in the video lines called VANC. This 
information can be for example Closed Captioning in the USA or OP-47 (Teletext) in Europe. 
OnTheAir Video will not write anything to these lines, but it will be transparent: if there are 
VANC lines in the Video signal, OnTheAir Video will send them to the Video Card which in 
turn may handle them or not.  

Before deciding for one card or the other, check with the manufacturer if VANC lines are 
supported and that this card is supported by your Softron application. 

Subtitling with OnTheAir Video 

OnTheAir Video 4 supports different ways to add subtitling to your video, either embedded 
in the video file directly, or as a sidecar file. Below are the supported formats and 
requirements. 

	 	 	  
	 	 	 CEA608/708 

• Embedded in a QuickTime media file: Supports a QuickTime Closed Captioning track, in 
CEA608 or CEA708. 

• Embedded in a MXF media file: Supports a Closed Captioning track in CEA708 
• Sidecar file: Supports SRT files*	  

	 	 	 OP47	  

• Embedded in a QuickTime media file: Not supported.	  
• Embedded in a MXF media file: VANC packets with DID 0x43/SDID 0x02	 
• Sidecar file: Supports SRT and STL file*	  

More information about CC in chapter “Closed Captioning”  

 

This list of supported codecs may have been updated. make sure to check 
the specifications section of the product page on our website.

https://softron.tv/products/play/ontheair-video?content=specs
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Software Installation  

1. Download the software from our website. 
2. Unzip the downloaded file. 
3. Drag and drop the OnTheAir Video (or OnTheAir Video Express) application into your 

applications folder. 

First Start 

1. Double click on the OnTheAir Video icon or select the icon in the Applications folder 
and use your File > Open command to launch the application. 

2. When prompted with the message that “OnTheAir Video.app is an application 
downloaded from the Internet. Are you sure you want to open it?” Click on Open. 

3. A license agreement window will open. Enter your name and email address for the 
registration. Tick the check-box and click on “Accept.” 

4. Enter an admin password to install the required components. 
5. If you have a dongle connected to the computer with valid licenses for OnTheAir Video, 

the application will start right away. 
6. If you do not have a dongle connected, a license window will open to offer you three 

choices: 
• Register: if you own a serial number, click on this button and follow the 

procedure to activate it. You can read more about the activation procedures on 
our support desk. 

• Buy: if you don’t have a serial number, but want to buy one, click on that button. 
• Demo: if you want to try the application in DEMO mode, click here. In DEMO 

mode, OnTheAir Video is fully functional. The only limitation is that a blue frame 
will be written to the file every few seconds. 

Note that the license window will only open the first time you start the application. If you 
want to add a license, or upgrade later on, you can access the license window in the 
Menu “OnTheAir Video 4 > License…”  

7. That’s it — you are ready to use OnTheAir Video 4! 

 

https://softron.tv/products/play/ontheair-video?content=downloads
https://softron.zendesk.com/hc/en-us/sections/201275327-Licenses-De-Activations-Dongles-Options
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1. Quick Start  

OnTheAir Video 4 (OTAV) is a very intuitive program, with a lot of features and functions. So 
before diving into the menus and features, that it offers, let’s first get you started real quick 
and start playing some files. For that, we will create a playlist… But first, we need to take a 
look at the OnTheAir Video settings.  

1.1. Set Up the Video and Audio Output. 

The first thing to configure is what video and audio output you will use. To do that, go to the 
menu “Settings > Outputs”.  
Select the device that will be used as the main video and audio output. A reminder that 
OTAV supports AJA, Blackmagic-Design and Deltacast cards and Thunderbolt devices, as 
well as NDI. 

You will find this window :  

In that area, you’ll also be able to set the Video Format, Pixel Format, Audio Channels and 
Sample Size of the audio. If you select the ARGB pixel format (when the card supports it),  
you will be able to select External or Internal Key and set if the Alpha is Premultiplied or not. 

We will not enter the full details right now. To have all the explanations on the outputs and 
the player settings available, go to chapter "Settings". 
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1.2. Add Files & Play 

Now that you have setup an output, we can start playing some files. For that, you can use 
the one that have been automatically created when you started OTAV, or you can create a 
new one by going to the menu “File > New Playlist”, or using the keyboard shortcut 
“command + N” (More shortcuts here). You should now have an empty playlist: 

Now you can add some files (a video, a still image, or an audio file) to your playlist by using 
any of these methods: 

• Drag-and-drop a file from the Finder 
• Select the menu “File > Add >  Media Files…”  (or alt + ⇧ + A ) and in the window that 

shows up, select any compatible media in your hard drive.  
Note that the clip will be added before the currently selected clip, Or if no clip is selected, at 
the end of the list. 

Once your files are in the playlist, start playing them: 
• Select the clip you want to play,  (if no clip is selected, we will start playing the first 

clip in the playlist) and: 
	 	 > Click on the green “Play” icon at the top of the window 
	 	 > Use the space bar, or an alternative way (GPI trigger, Stream Deck…) 

• Or simply double-click on a clip.  

That’s it, your first file starts playing out!  

 

 Note that there is an option (Double click inspects instead of playing) that 
will change that behavior, so if double-clicking on the clip opens the 
inspector instead of starting the playback, you can check the “OnTheAir 
Video > Settings > General”.
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1.3. Output Preview 

Now, let’s view what you are playing out. For this open the output preview window either by: 

• Selecting the menu “Window > Output Preview” 
• Using the keyboard shortcut “command + ⇧ + p” 

This will open a preview window : 

This window can be resized and could even be set in full screen on an external monitor. 
However, we don not recommend using this as a broadcast output., This preview window, as 

its name implies is made for preview. For a broadcast operation, you can use affordable 
devices from AJA and Blackmagic-Design, which both have small Thunderbolt devices with 
HDMI support. 

Now that you have a small glimpse of OnTheAir Video 4, we will go through each feature of 
the Menu : the settings and window. Let’s start with the playlist.  

 

 OTAV is what is called a “Document based” application as its is based on 
documents (playlists). Our playlists are simple documents that you can 
save an copy to a different storage, as you would with any other type of 
document on your computer, so it’s very easy to handle.
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2. The Playlist 

A quick reminder: to create a new playlist go to the top menu “File > New Playlist”, or use the 
keyboard shortcut “command + n”. 

2.1. The User Interface 

Here is a classic playlist window, each feature is described hereafter :  

2.1.1. The Title Bar 

This is the Title Bar of the playlist currently being played, and it shows which output is being 
used for the playlist. If Smart Resize is being utilized, it will show this next to the Output. 
 
You can change the title by clicking on the ⌄; 
this will open a popup that allows you to select 
the title, any tags associated with the file, and 
the location of the file. 
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2.1.2. The Timecode Bar  

This bar shows time information for the playing clip: 

• The larger number on the left shows how long the clip has been playing, while the one on 
the right shows how much time remains on the clip.  

• Note that by right-clicking on either of those time information you can change them to read 
the playing time / time remaining on the playlist as a whole, rather than just the clip in play.  

• Between those time information are two bars: The blue bar shows the progression of the 
clip, while the red bar shows the progression of the playlist.  

• Double- clicking on the blue bar opens the scrubbing line, and by clicking at any point on 
the line you may move the clip to that point.  

• Above the bars are two smaller time information; the one on the left shows the current 
playtime of the clip in play, while the timecode on the right shows the entire duration of the 
playlist.  

• Below the bars is the title of the clip currently in play. 

2.1.3. Playback Controls  

The Playback Controls will be familiar to almost everyone. They are, from left to right:  
Play Previous Clip - Stop Clip - Pause Clip - Skip to Next Clip - Lock 

 Clicking on the Lock button disables most of the functions on the UI, preventing anyone 
from inadvertently clicking on a button while the playlist is playing out, potentially disrupting 
the playout. Clicking again on the Lock button unlocks the functions. 
 

2.1.4. Playlist Settings  

To the right of the Playback Controls, you have an 
ellipsis icon.  
It allows you to set a preset duration for your 
playlist. For example, if you want a one hour 
program, the playlist will show you the runtime and 
the under runtime.  
Very useful with the scheduler option. Explained in 
the chapter "Scheduler". 
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To the right of this icon, there is the Detail Level panel, and these controls allow you to 
select how much detail is displayed about the clips in the playlist.  

There are three levels of detail that may be selected:  
• The lowest level shows only three things about the clip: how much time into the 

playlist the clip will start; the clipʼs title; and the duration of the clip.  
• The second level of detail shows the above information, and also shows a still shot 

from each clip.  
• The third level displays the above information, plus the video format of the file and 

the date and time that the clip was created. 
 
To the right of the Detail Level panel are the four Options buttons: 

 

The Chain button sets the playlist to automatically play each clip in succession. 

The Loop button causes the clip to reply after it finishes playing. If the Chain button and the 
Loop button are both in use, the clips will play in order, and the playlist will  replay from the 
beginning upon the completion of the final clip. 

The Randomize button makes a random mix with all the clips inside the playlist. It allows you 
to play it multiple times, with the same clips, but with a unique sequence every time. 

The Cue button puts OnTheAir Video into Cue Mode. While in Cue Mode, each clip will stop 
on the last frame. The user will then have to click the Play button (or hit the space bar) to go 
the next clip, where it will pause on the first frame. Clicking Play again (or pushing the space 
bar) will start the clip. Note that the Cue Mode cannot be enabled while the Chain or Loop 
functions are enabled. 

2.2.  The Different Clips 

To add a clip in your playlist. Go to the top menu “File > Add”. You have different options: 
• Media files: Videos in your files. 
• Clip by ID: Use the ID to add the clip. 
• Live Clip: From a live source.  
• Stream Clip: From a stream source. 

Go to chapter "Streaming inputs in 
OTAV". 

• Offline Clip: An empty file for a clip 
that is not exported yet. 

• Comment: Text you want to put 
between the clips of your playlist.  

 

2 3 41



-  -17

OnTheAir Video User Manual

2.3. Contextual Menu 

Below the Playback Controls, Detail Levels, and Options is the Playlist Queue. You can drag 
clips into the playlist or open a previously constructed playlist. Right-clicking on a clip opens 
a popup with a number of options for that clip. The function of each option is described 
briefly: 

• Set Attributes...: This feature 
brings up the Clip Inspector for 
the highlighted file, and is open 
to the Attributes tab. For more 
information, see the window 
menu: Clip Inspector. 

• Set In/Out Point...: This brings 
up the Clip Inspector as well, 
open to the Timeline tab. 

• Set Auto Start Date/Time…: 
When put on a clip, it will 
automatically play it at the time 
set (time and date). A unique 
clock will appear on the select 
playlist. Clear will disable the 
setting.  

• Play/Clear Next: Choose the 
next clip of the playlist you want 
to play.  

• Disable/Enable: This will disable 
or enable the broadcast of the 
clip in the playlist. 

• Reveal in Finder/Media 
Browser: This opens the Finder 
or Media Browser window, 
showcasing the selected clip in 
its Folder. 

• Edit Description…: When you want to replace a clip by another one, it is quicker to 
just enter its ID, rather than searching for it in the playlist. You just need the traffic 
option and have correctly set the media folder. 

• Replace…: This opens the Finder window as well, listing the files in your selected 
Media Folder. From there you can click on a file you would like to use in place of the 
highlighted clip in the playlist; clicking the Open button replaces the original clip. 

• Replace/add by ID…: Replace or a clip using its identifier 
• Export as XPLI…: Export a file containing information related to the clip (like set 

attributes, In/Out Point…). See the window menu: Clip Inspector.  
• Force Revalidation: To make a new verification of the information related to the clip. 
• Assign MIDI Input Message...:  Allows you to assign a MIDI note to control the clip. 
• Configure MIDI Output Message: This allows you to set the Channel and Note 

	 for use with MIDI.  
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2.4. Folder-Based Playlist 

A Folder-Based Playlist allows you to control your playlist via a folder. To create one:  
• Go to the top menu “File > New Folder-Based Playlist” 

• Use “⇧ + command + n” 
When it is created, OnTheAir Video will ask you to select the folder you want to use with this 
playlist. 

On the right, an example:  
• Here is a Folder-Based Playlist and 

the folder that is used in the 
Finder.  

• At the top (surrounded by red), you 
can see a file logo. It means this 
playlist is Folder-Based. If you click 
on the logo, it will open the folder 
in your Finder.  

• Four clips were added in this 
folder and they appeared in the 
playlist.  

• You can add and remove clips from 
the folder. It will automatically 
update the playlist.  

2.5. Remote Playlist 
Not available in OnTheAir Video Express. 
You need to buy the Remote pack option for OnTheAir Video.  

It gives you the ability to open a playlist from another OnTheAir Video on another computer. 
To do that you have to use the remote control option, explained in the chapter "Remote 
Control". 
The Remote playlist has a different tab:  

It gives you the name of the payout channel and also the lists of all the playlists open on that 
computer. You can also create a new playlist, which will be stored on the Media Folder from 
that computer. Everything is explained in the chapter "Remote Control". 

 

https://store.softron.tv/product_info.php?cPath=45_27&products_id=247
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3. Settings 

To set up your OnTheAir Video you will also need to go to 
the top menu. To begin, Click on the “OnTheAir Video” tab 
on the menu bar brings up a list of options. 

If you open “About OnTheAir Video…”, this brings up some 
basic information about OnTheAir Video, including the 
version number, license information, and copyright 
information. Clicking on the More Info... button opens up 
another window wherein are displayed any options (such as 
Dynamic Graphics Overlay, Closed Captioning, Remote 
Pack…) you have enabled on your OTAV license. 

The Settings panel (formerly called “Preferences…”) is very 
important to set up your OnTheAir Video. You already saw an overview of the “outputs” in 
chapter "Quick Start". Now we will go further through each option. 

3.1. General 

Clicking this opens the General panel, which allows you to set defaults for your OnTheAir 
playlists and clips. This will not affect anything in the current playlist, but rather anything 
dragged into the playlist from another folder. 
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3.1.1. Default Playlist Settings  

Default Playlist Settings:  
• Chain: With this box enabled, newly added clips will be in Chain mode. The clips are 

played in succession. 

• Loop: When this box is enabled, newly added clips will be in Loop mode. It causes the clip 
to reply after it finishes playing. 

• Cue: When this box is enabled, newly added clips will be in Cue mode. The clip will stop 
on the last frame. 

• Shuffle: When this box is enabled, newly added clips will be in Shuffle mode. It makes a 
random mix with all the clips inside the playlist. 

Default Item Settings: 
• Resize Mode: Here you can select from three resize modes: Fill; Pan & Scan; and 

Letterbox. 

• Clip End Behaviour: Here you can set what happens at the end of a clip dragged into the 
playlist. If Normal is selected, the playlist will continue as before. If Stop at End, the clip will 
stop when it finishes playing. If Hold Last Frame, the clip will stop at the end and hold in its 
last frame. If Play Next Clip is selected, the next clip will play immediately after the added 
clip finishes. If Loop is selected, the clip will replay when it finishes playing. 

• Start Transition: Allows you to add a transition between all the clips. A list of transitions is 
available but you can also edit your own. You can also set the Image duration and the 
transition duration just below.  

• Hold Mode: If Last frame is selected, the last frame known will be used on hold. If To Black 
is selected, a black frame will be used instead. 

• When Looping on a Clip: If Repeat Trans. is enabled, the start transition will be played 
every time the clip loops. If Repeat Actions is enabled, the action assigned to the clip will 
be played every time the clip loops. 
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Playback Controls:  
• Space Bar Pauses/Resumes Playback: When enabled, the space bar will pause or resume 

playback instead of restarting the clip from the beginning.  

• Disable direct Keyboard Shortcuts: When enabled, keyboard shortcuts that do not require 
a modifier key (alt  /command / ⇧) will be ignored.  

• Double-Click Inspects instead of Playing: When enabled, double clicking a clip, will open 
it in the inspector instead of start playing it.  

• Auto Cue: When enabled, and the playlist is in cue mode, OTAV will automatically cue the 
next clip two seconds after it hold the last frame of the previous clip.  

Other Settings:  
• Auto Save / Versions: When enabled, the playlist documents will automatically save when 

modifications are done. When disabled, you will also lose the versions for this document. 
Make sure that this works fine in your workflow.  

• Auto check for missing clips: When enabled, each open playlist will check after missing 
clip every 10 seconds.  

• Color text with Finder tag color: When enabled, the text of the entire playlist row will be 
displayed in the color of the Finder tag used for that clip. 

• Include offline clips durations: When enabled, offline clips duration are counted in when 
computing the next clip start time and playlist duration.  

• Auto-update start times: When enabled, the start times are recalculated every time a clip 
is started according the realtime clock. Not available in OnTheAir Video Express.  

• Auto-lock Scheduled Playlists: When enabled, the scheduler will automatically lock the 
playlists when it opens them. More information about the scheduler in chapter.… Not 
available in OnTheAir Video Express. 
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3.1.2. Logs  

Logs are files containing information about activities in a computer system. In the case of 
OnTheAir Video, it helps to understand what is happening in the app. For example, if you 
encounter an issue while using OTAV, read the logs may help you find the solution. 
Next to “Defaults”, you will find this “Logs” window : 

Technical Logs Folder:  
The folder where are stored some "technical logs" that are useful. 
OnTheAir Video allows you to save the logs in a different folder (If you have changed that 
preference, please make sure to look in the appropriate folder). If you did not change the 
default location of those logs, you can access these logs as explained below: 
There will be one file created per day, and that these files are deleted automatically after 
one month. 

 

As-Run Logs Folder:  
Not available in OnTheAir Video Express.  
OnTheAir Video can generate "As-run logs" that can be used to know which clips has been 
broadcasted when. As-run-logs are saved in the folder selected in "Settings > General > As-
Run Logs Folder”. 
Once properly configured, OnTheAir Video will create one Log file every day. Each Log file 
will be named as this: 
OnTheAir Video Log 2024-02-28.txt 

The Log file generated is a tab-separated file that can be analyzed using the free application 
"LogAnalyzer" that you can download from our website or it can also be analyzed by any 
other traffic system. 

To understand how to analyze As-Run Logs, go to our website article.  

 

If you need to report an issue using the “Contact Softron Support” menu, our 
team will often needs to have access the technical and system logs. So make 
sure the option “Attach Logs Automatically” is enabled. To find more information, 
go to our website. You can also retrieve manually the logs, to do so, find all the 
steps in our website article. 

https://softron.tv/products/play/ontheair-video?content=downloads
https://softron.zendesk.com/hc/en-us/articles/207696687-HOW-TO-Analyze-As-Run-logs
https://softron.zendesk.com/hc/en-us/articles/207695667-HOW-TO-Report-an-issue-using-the-Contact-Softron-Support-menu
https://softron.zendesk.com/hc/en-us/articles/207695367-HOW-TO-Manually-retrieve-all-the-logs
https://softron.zendesk.com/hc/en-us/articles/207695367-HOW-TO-Manually-retrieve-all-the-logs
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3.1.3. Media 

Media Folder: 
A Media Folder is kind of a watch folder for OnTheAir Video where it finds the media that it 
has to play. Once you indicate such a Media Folder to OnTheAir Video, it scans the locations 
that you indicated and shows the list of media available to your application. 

Media Browser:  
Not available in OnTheAir Video Express 
Add support for a local or remote media browser. To learn more about the Remote Pack of 
OnTheAir Video, go to chapter "Remote Control".  

3.1.4. HTTP Server 
Not available in OnTheAir Video Express. 

If the Remote Control is Enable, you can change the options :  
• Server Name: the name that will be 

displayed when you'll try to 
connect to it 

• Port Number: is the port number 
that will be used to communicate 
with it. Depending on your FireWall 
configuration, you may want to 
change that, but otherwise leave it 
to the default value (8080) 

• Web Pages Folder: If you have 
created one or several web pages 
to interact with MovieRecorder, you 
can select the folder containing 
those pages and it will be hosted 
by MovieRecorder. If I had a page 
called "Custom.html" in a folder 
selected, it could be reached at 
127.0.0.1:8080/Custom.html 

• Require Authentication: Where 
you can choose the users that have 
access to your OnTheAir Video…. 
You can add/Remove them and 
also set a password.  

 



-  -24

OnTheAir Video User Manual

3.2. Outputs 

Clicking this opens the Outputs panel, which allows you to set up your Player Settings. Any 
changes made to the Outputs settings must be saved by clicking the Apply button on the 
bottom right hand corner of the panel. 
Select the device that will be used as the main video and audio output. A reminder that 
OTAV supports AJA, Blackmagic-Design and Deltacast cards and Thunderbolt devices, as 
well as NDI. 

Different options are included (available options depend on the video device used): 
  
• Video & Audio Output Device: This 

allows you to select any available 
video outputs to play and/ or record 
your playlist. 

• Video Format: From here you may 
select the format you would like to 
play out your clips. The list is quite 
extensive (60 different formats), 
ranging from SD to 4k. 

• Pixel Format: You may choose either 
YUV 8 bits, YUV 10 bits or ARGB as 
your Pixel Format. 

• Audio Channels: You may select 1,  2, 
8, 16, 32 or 64 audio channels. 

• Sample Size: Your Sample Size may 
be either 16 or 32 bits per package. 

Below that is the option to Enable SMART Resize and Graphics. When the box is checked, 
OnTheAir Video will automatically resize interlaced videos, and it will allow you to overlay 
logo and transitions. Note that this option will use more processing power from your 
graphics card. The Release button allows other users to utilize the graphics card even as 
you use OnTheAir Video. More information in chapter "Graphics".  

You can also set a Secondary Audio Output.  
Not available in OnTheAir Video Express. 
Additionally to the video output on the selected video device, you can now also output to 
another available audio output on your Mac. Works with CoreAudio, so supports the audio 
devices that are available for macOS (including Dante or MADI). 
For this device, you can also select the numbers of audio channels.  
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3.3. Inputs or “Live Sources” 
Not available in OnTheAir Video Express. 

In the inputs settings, you can handle your “Live sources”.  

A Live Source allows you to select an 
incoming video signal and output it 
instead of playing back a clip. 

For that you will need an additional 
video input. This additional video input 
can be on the same device that you use 
for output if it supports it, or it can be a 
different video device. Note that you 
can use more than one additional input 
and you will thus be able to switch from 
one to the other. You will want to make 
sure that these sources are genlocked 
for a better result. 

Once you have made sure that you have an additional video input. Click on the “+” icon to 
create a new Live Source. When you create it, you can set: 
• Live Source Name: what will be displayed in the menu when you will create the Live item 

in the playlist.  
• Video Device Input: this is where you select the Video Device to use, and below that you 

set the other settings such as Mute Audio or Level +20B. With Varying Frame Rate, you can 
use a different frame rate. We will duplicate or drop frames to maintain sync, and if it is a 
different size, we will scale it to match the output resolution. You can also choose to 
process SCTE triggers that are embedded.  

You can create multiple Live Sources. 

3.3.1. Add Live Clips to a Playlist 

To add a Live Clip to a playlist you can: 
• Go to the menu "File > Add Live Clip…" 

• Use the keyboard shortcut “alt + ⇧ + l” 

A window will popup where you can set: 
• A Name for your Live Clip. 
• Live Source Name: Select the one you want to 

use here 
• Duration: set the duration of your Live. 

Note that a "Live Clip" behaves the same way as a 
regular video clip. If you need more information 
about Live Sources, go to our website article.  

 

https://softron.zendesk.com/hc/en-us/articles/207695607-How-many-inputs-and-or-outputs-do-you-have-on-a-single-video-device-
https://softron.zendesk.com/hc/en-us/articles/215007608-HOW-TO-Use-Live-Sources-in-OnTheAir-Video
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3.4. The Other Settings  

In the settings menu, there is also 5 other windows (only “Triggers” available with OnTheAir 
Video Express): 

They are linked with important features in OnTheAir Video. The explanations can be found in 
the next chapters :  

• Graphics: In chapter “Graphics” 

• Triggers: In chapter “External Controls and Integration” 

• Actions: In chapter “External Controls and Integration” 

• Captions: In chapter “Closed Captioning”  

• EPG:  In chapter “EPG option” 
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4. Clip Inspector 

By highlighting a clip on your playlist and opening Clip Inspector, you open some useful 
functions and information available for that clip. To open the Clip Inspector: 
• Go to the top menu “Window > Clip Inspector”  
• Use “command + i” 

There are five tabs within the Clip Inspector: Attributes, Timeline, Graphics, Metadata, and 
Info. 

4.1. Attributes 

This panel reveals important information about the clip in play, and allows you to change 
some of its attributes. 

• At the top of the panel will be shown the Title of the clip.  
• The Clip End Behaviour: the default is Normal, and the clip will end as per the indicated in 

the playlistʼs Options. The behavior may be modified to any of the following options: Stop 
at End, Hold Last Frame, Play Next Clip, and Loop. 

• GPI Trigger: Set a GPI input to monitor that will do a skip next.  
• The Resize Mode: your options are Fill, Pan & Scan, and Letterbox. Below that is a box 

that, if checked, Reverses the Field Order. 
• Start Transition: Choose a transition to put on the start of the clip.  
• The Logo Overlay: choose the static graphic you want to use. Explained in chapter 

"Graphics".  
• Below that is a sliding bar with which you may adjust the clipʼs Audio Gain. You may also 

start automatically the clip at the time desired. 
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4.2. Timeline 

The next tab is the Timeline Tab, which will show a large still shot of the playing clip. 
 

• The current position: You can move forward or backward into the clip via a sliding bar 
beneath the still; you may also hit the play button to play the clip. Above and to the right of 
the still is the total duration of the clip. 

• In Point: wherein the starting point of the clip is indicated (typically 00:00:00 unless 
modified).  

• Media Duration: showing the duration of the clip.  
• Out Point: showing at what point in the clip the video ends (typically the time of the last 

frame of the clip, unless modified). The In-Point and Out-Point time clocks can modified, 
thus changing the starting time within the clip and/ or the ending time within the clip; when 
either of the these attributes is changed, the Media Duration changes to match the current 
duration of the clip.  

• Mark, Go, and Clear: Mark saves the In/ Out Point, Go sends the clip to the position of the 
In/ Out Point, and Clear resets the In/ Out Points to the original times. 

• Actions: within which you may set up (or remove) AppleScript events within the clip, at a 
specified time within the clip. 

 



-  -29

OnTheAir Video User Manual

4.3. Graphics 

The graphics tab allows you to add and 
control graphics on the clip selected. It 
uses the clip inspector and also the 
settings window, with a path to your 
Character Generator (CG) projects.  

To create CG with OnTheAir Video, you 
can use our free software: OnTheAir CG 
Designer. Available on our website.  

We won’t go further in how to set up 
Graphics. Everything is explained in the 
chapter “Graphics”. 

4.4. Metadata  

The Metadata tab shows some metadata inherent to the clip. 

4.5. Info  

The Info tab shows some important information about the clip, such as its source, size, 
format, and so on. 

 

https://softron.tv/products/play/ontheair-video?content=downloads
https://softron.tv/products/play/ontheair-video?content=downloads
https://softron.tv/products/play/ontheair-video?content=downloads
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5. Output Preview 

Reminder to open the output preview window: 
• Selecting the menu “Window > Output Preview” 
• Using the keyboard shortcut “ command + ⇧ +  p ” 

An example of a clip playing in a virtual output, that you can see in the output preview : 

At the bottom of the window, you can see three buttons that allow you to change some 
settings:  

5.1. Mute  

The first “Speaker” icon allows you to Mute/Unmute the audio preview. 

5.2. Audio Channels 

The second icon allows you to set audio settings for the preview.  Note that these settings 
do not change anything in the audio that goes out your video device, it only changes for the 
audio preview. To change the gain on a clip, go in “Inspector > Attributes”. To change the 
number of channels that are displayed in the VUMeters and in the mapping window, change 
the number of audio channels in “OnTheAir Video > Settings > Outputs >  Player Settings > 
Audio Channels”. 
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Here’s the window for the audio preview settings: 

To enable/Disable an audio channel, tick the checkboxes, or right-click on them to enable/
disable multiple channels at once. You can either perform the action on all channels, or only 
on the selected ones. To select some channels, click on the VU meter section. 

To change the gain of each channel, use the slider, or manually enter a value in the field. 

5.3. Video  

In this window, you can set the video preview quality and refresh rate. Note that in some 
cases (such as if you do remote control), it may be important to lower the refresh rate so you 
don’t use too much resources of your computer. 

You can also set that the Output Preview window always remains on top of all windows by 
enabling the Float on Top option. 
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6. Scheduler 
Not available in OnTheAir Video Express. 

You can schedule playlists to be played automatically at given time of days. OnTheAir Video 
can play 24/7 for days and days without having to worry about it. A feature that is used a lot 
by TV stations as their main automation software.  

6.1. Create a Schedule  

First, you have to open the output preview window: 
• Selecting the menu “Scheduling > New Planner Schedule… > Save as … .xml” 

• You can also open a pre-existing 
Schedule, close, save or reload the one 
you are using.  

• Two windows are available: the 
Schedule and the Planner Schedule. 
The differences are explained in this 
chapter.  

• Enable/Disable Scheduling to start or 
stop playing the clips in your schedule. 

• Resynchronize Scheduler to start 
playing the clip planned at this time.  

• You can add event, playlists and offline 
playlist.  

Once the new Planner schedule is open, you will see this window :  

This is a blank 
schedule. Now you 
need to create an 
event, in which we will 
add a playlist, a folder-
based playlist or an 
offline playlist 
(you can put or drag 
multiple playlists at the 
same time). 

But first, to create an 
event:  
Go to the bottom left 
of the window and 
press the “+” option.  

 



-  -33

OnTheAir Video User Manual

When you create an event, a new window will appear: 

Here you can rename your event and choose 
between two very important options: 

• Specific Date: Your event will only be played at a 
special day and at a special time.  

• Weekly Repeated: You can have daily, weekly, 
weekdays and weekend events. Choose and 
set up that events, it will keep occurring. 

In either case, you then set a start and an end time, 
so that you can set the duration of your event.  

 

In this window, you can already add playlists with the “+”. You can also remove playlists with 
the “-“. These options are also available in the main window we saw before. 

6.2. Playlists in Scheduler 

You can add one big playlist in your event, or use multiple 
playlists. You can use "standard" playlists, but you can also use 
folder-based playlists… There are many ways to set up your 
events. Here is an example of a one hour show, made up of 
three playlists, and visible in the scheduler:  
Three "playback mode" can be set for each playlist:  

Loop: The scheduler will open the playlist in Loop mode. At the 
end of the playlist, playback will start again at the beginning. 
This means that if you have other playlists after that one in your 
event, they will not play. 

Shuffle: The scheduler will open the playlist in Shuffle 
mode, which behaves the same way music shuffle does: 
randomly play one clip after another. So that playlist will f 
play forever, until a next event starts. If you have other 
playlists after that one in your event, they will not play. 

 

  If two events occur at the same hour and at the same day, the one set at a 
"Specific Date" will take priority on the other. At the end of it, it will not 
automatically go back to the "Weekly Repeated" event, so make sure to set both 
event to the same duration. 

2 31

2

1
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Randomize: Makes a random mix of all the clips inside the playlist. The advantage of this 
compared to shuffle mode is that each clip in the playlist will play just once, and if the playlist 
is not in loop mode, it will be play for a fixed duration, and other playlists after it in the event 
will be played. 

Note that some of these playback modes are exclusive. You can not use the  random and 
shuffle mode at the same time for example. 

6.2.1. Playlist Duration 

As we saw in chapter "The Playlist", if you add live clips in your playlist (for live events), you 
won’t be able to know exactly the length of your event. Other case: your playlists don’t reach 
the exact duration of your event.  

Let us use the same example as before, but one of the playlist is shorter. You can see a 
timing issue in the Difference panel and an exclamation mark next to the event:  

In these 1-hour show, it means there is 22 seconds missing. The timing isn’t correct anymore. 
An easy way to fix this issue is to create billboards: Add a playlist at the end of your event 
(with commercials for example) and select the Loop Option. It will keep something going 
until the start time of a new event.  

 

6.2.2. Offline Playlist  

The offline playlist is created when you are making OnTheAir Video playlists in a third-party 
software (created or developed by a different company) or on a different computer with 
OnTheAir Video. An offline playlist is “empty” at first. Then the playlist is added through 
another computer or the third-party software.   

An example below, the 8pm show has been created with an offline playlist. It is already 
planned in the schedule, but the playlist is missing.  

 

 When you enable your schedule in OnTheAir Video, it will automatically  
play the clip scheduled at this very moment.

3
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In this example, we use our documents folder. When the 8PM show playlist is created. It is 
automatically added in the event: 
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6.3. Organize the Schedule 

Go to the top left of the window, there you will find different option to visualize the Schedule: 

• Show: You can decide the numbers of days shown in the schedule. The first one of the list 
is today. You can go from 1 to 18 days visible in the Planner. 

• < or >: Go to the day before or the day after. 
• Now: Puts you in front of what is currently playing in the Schedule.  
• Calendar: Choose the day you want to visualize in the Schedule.  

6.4. The “Classic” Schedule Window (Version 4.0 or 
later) 

First select the menu “Scheduling > Show Schedule Window” 

This window offers the same 
features as the Planner Schedule 
Window, it is the “traditional” 
Schedule window from OnTheAir 
Video. 
If you are working 24/7 with the 
Planner Schedule, you will have a lot 
of events to deal with. It can become 
very difficult to understand what is 
going on in this schedule window. 
Specific Date events mixed with 
Weekly Repeated events won’t help 
you visualize what is planned today, 
tomorrow or during the weekend…  

 

6.4.1. The Show Filter  

To organize this Schedule, Open the Show Filer on to the top right 
corner of the Schedule Window. Click on “Show: All” and this window 
will pop up:  

Here you can select only the day you care about. The scheduler will 
show you the events of the day you selected, in the correct running 
order.  

If you need more information about the scheduler. Videos are also 
available in our Youtube Page you can find with this link. 

 

https://www.youtube.com/watch?v=Bnea5-sWOoE&t=307s&ab_channel=SoftronMediaServices
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7. Graphics 

You can add dynamic graphics and static graphics to your clips and outputs. In this chapter, 
we will see what is the difference between static and dynamic graphics, how to create them 
and how to set these up in OnTheAir Video.  

7.1. Static or Dynamic Graphic? 

• A static graphic is a fixed image, such as a company or a TV logo.  
• A dynamic graphic goes further. It is an overlay that changes based on new information, 

context or user input. For examples: a digital clock, a ticker, game stats…  

7.2. Create a Graphic with OnTheAir CG Designer 

If you want to create a Dynamic/Static Graphic, you can download our free software:  
OnTheAir CG Designer. More information available at softron.tv.  

For each CG project, you can create an unlimited number of items. The only limitation will be 
what your computer can handle. You can add text (fixed or with moving), shapes, still images, 
movies, clocks (digital or analog), or Live items. Each can be customized and positioned in 
the CG project very easily. Each item can then be "timed" in the timeline, set when it will 
"appear" and you can define animations such as fades, pushes, and moves. 
To know how to use OnTheAir CG Designer, see our Youtube videos presentation.  
More information on our website.  

 

 To use dynamic graphics in OnTheAir Video, you need the Dynamic Graphic 
Overlay option. Not available in OnTheAir Video Express. 

https://softron-downloads.s3.amazonaws.com/apps/OnTheAir_CG_3.zip
https://softron.tv/products/play/ontheair-cg
https://www.youtube.com/playlist?list=PL0PwvpZ9S7h4SxWzVscYsss3L81CAXyYB
https://softron.zendesk.com/hc/en-us/sections/201275247-OnTheAir-CG-3
https://store.softron.tv/product_info.php?products_id=117
https://store.softron.tv/product_info.php?products_id=117
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7.3. Set Up your Static and Dynamic Graphics 

First you need to go to the settings and enable a very important option:  
 

7.3.1. SMART Resize & 
Graphics 

Go to the top menu “OnTheAir Video > Settings… 
> Outputs” 

Make sure this option (surrounded by red in this 
picture) is enabled: 
• You will be able to overlay graphics. 
• The resize of interlaced material will be done 

with a much better quality. 
But also when the option is enabled, it will use 
much more the Graphics card and thus you will 
need a decent Graphics card. So if you don't 
need to resize interlaced video, nor overlay 
graphics, we would recommend you to leave the 
option disabled. 

7.3.2. In the Settings  

Now that the SMART resize & Graphics is enable, we will set up a graphic and a logo to your 
output. For that, stay in the settings. Next to the Outputs, there is the Graphics Settings : 

First, how to set up a Static Graphic:  
• Folder Path: the path to the folder where 

you will place your logos. 
• Default Logo: Once you have selected a 

folder with supported files, you will be 
able to select amongst them the logo that 
will be used by default. 

• Overlay logo by default: Sets wether the 
default logo will be overlaid on the clips 
you drag to a playlist. This option doesn’t 
change playlists that were already created, 
it will simply turn on the logo overlay 
option on all clips that you drag and drop 
to a playlist after the option was enabled. 

• Automatically use images as logos: When 
enabled, an image file with the same name 
as the video clip and located in the same 
folder will automatically be used as a logo 
for that clip. This is very convenient to 
overlay a specific graphics over a specific clip automatically, just enable this option and 
place in the same folder a movie and logo file with the same name. 

 



-  -39

OnTheAir Video User Manual

Two recommendations with Static Graphics in OnTheAir Video:  
• File type. We recommend using .png files, but other formats are supported (tga, ...). Make 

sure it has an alpha channel and to test it before using it. 
• Size. The logo file must be the same size as your playback output settings. You won't be 

able to change its location, so make sure to place the logo or graphics where you need it. 
More details in this article. 

Now, how to set up a Dynamic Graphic:  
Not available in OnTheAir Video Express. 
• In the window CG projects, you can add the 

graphics you created with OnTheAir CG 
Designer. 

• Just press the “+” button in the bottom left.  
• Then open your CG projects. Note that you 

can add multiple CG projects. They will be 
visible in the list.  

• If you want to remove a CG project from 
the list. Just press the “-” button 

• The default “State” of each projects is 
disable. Just press to enable the CG 
projects to your OnTheAir Video.  

 

7.3.3. With the Clip Inspector 

When you set up a graphic from the OnTheAir Video Settings, this graphic will appear on all 
the clips in the playlists. To set up a CG project on a single clip, use the Clip Inspector: 
• First select the clip you want to set up. 

Then open the Clip Inspector go to 
the Top menu “Window > Clip 
Inspector”) and go to the Graphics.  

• You will see the list of all the Graphics 
(CG project) you added in the Settings. 

• Each Graphic is in “Default” mode. It 
means the Graphic will Run/Stop 
depending on what has been applied 
in the Settings. 

• With the Clip Inspector, you can go 
further and decide if you want to 
enable (Run) or disable (Stop) each CG 
project on this clip only.  

You can also control the project from the actions, explanations in chapter External Controls 
and Integration. 
 

Note that you can use a Sidecar file: If your Graphic file has the same name as your 
Clip file, and are stored in the same folder, it will be automatically played on that clip. 
With this technic, you can set each clip with a different Static Graphic. It only works 
with Static Graphics.  

https://softron.zendesk.com/hc/en-us/articles/360003997134-HOW-TO-Use-the-logo-overlay-option-of-OnTheAir-Video
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8. Transitions 
Not available in OnTheAir Video Express. 

Add transitions to bring even more dynamic to your playlist. You can use either built-in 
transitions, or custom transitions (made with your own movies with an Alpha Channel). 

8.1. Set Up a Transition 

Select a clip in your playlist and open the Clip Inspector. (“Top menu > Window > Clip 
Inspector”). In the Attributes section, click on 
“Start Transition:” 
There you have access to a large list of Built-in 
transitions: 
• Dissolves effects 

• Push effects 

• Wipe effects 

> Click on the transition you want. It will be 
added to the clip. If there is another clip just 
before, the transition will be played between 
the two clips.  
Note that in the playlist, the clip has a yellow 
bar to indicate there is a Start Transition. 

The playlist will also update is length as it gives a time feedback from the transitions. 
You can also create custom transitions using our Transition Editor. It will be automatically 
added to the list.  
 

8.2. Transition Editor 

To create a custom transition:  
• Go to the top menu “Window > 

Transition Editor” 
• Use the keyboard shortcut 

“ command + shift + p ” 

The Transition Editor window will 
open. There you can see the list of 
Built-in transitions. Now press on 
the “+” in the bottom left to add a 
custom project. 
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Now add your movie (made with Alpha Channel for example) to the Transition Editor. A new 
category is created: the Custom Transitions. Projects are visible in the window:  

You can adjust the Playhead from the beginning and the end point manually. But you can 
also do it automatically by using the Magic Wand.   
The Magic Wand will determine the best position and time for your actual clips (A and B) and 
for the transition.   

• Premultiply RGB by alpha: When enable, it applies the transparency (alpha) to the color of 
the graphics. When disable, the outputting is straight.  

• The camera (next to the Magic Wand) can be used to determine the thumbnail of the 
transition.  

To see a full tutorial about the Transition Editor, go to our Youtube Channel.  

 

https://www.youtube.com/watch?v=6u1SbXNk7ys&ab_channel=SoftronMediaServices
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9. Streaming Inputs in OnTheAir Video  
Not available in OnTheAir Video Express. 

Streaming inputs for OnTheAir Video simplify the playlist workflow. For the most up to date 
list of supported stream types in OnTheAir Video, visit our web page under: Tech specs. 

In OnTheAir Video, when your playlist is open. Click “File>Add>Stream Clip…” 

In the new window:  
• Name: Give the stream clip a title 
• URL: The stream URL  
• Duration: Set the duration of your clip 
• You can choose to enable the Include in Auto 

Check for Missing Clips option: when enabled, 
the playlist will check for missing clips every 10 
seconds. If your stream is reliable, we advice not 
to enable this option, because it’s using more 
computer resources.  

For your testing, here is a website where you can 
find public streaming videos: 
https://www.cotrip.org/home 

 

Once you have saved that address, 
OnTheAir Video will validate the address 
and it will be ready to play. A useful feature 
is you can actually preview the clip in clip 
inspector like any other clip.  

 

https://www.softron.tv/products/play/ontheair-video?content=specs
https://www.cotrip.org/home
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10. Closed Captioning 
Not available in OnTheAir Video Express. 

To use this feature, you need to buy the Closed Captioning (CC) option for OnTheAir Video. 
This option enables the output (in the SDI output) of Closed Captioning, Subtitle (OP47) and 
VANC data such as SCTE35. 

10.1. Requirements 

To output Closed Captioning or OP47, you will need: 

• A valid license of OnTheAir Video 4, plus the CC option. 

• A video device that supports to output VANCs (all recent cards that we support and 
that have a SDI output should work fine, but older models of Blackmagic devices may 
not support it). For AJA cards, you need to enable VANCs in AJA Control Panel. 

Note that we write the CC or OP47 info in the VANC of an SDI output, so this will only work 
with an SDI output. When using the direct link (for example to send video from one of our 
playout application to another), the CC or OP47 are preserved. 

10.2. Supported Types 

* To know how to format SRT files. Go to our website article in which everything is 
explained. 

10.2.1. Formatting the SRT File 

As explained above, for OnTheAir Video to use a sidecar SRT file, it must be placed in the 
same folder as the video file, and bear the same name, with the .srt extension. 
A SRT file is very easy to create as it's basically a text file, with information of time. Here is 
how it looks like: 

1
00:00:00,980 --> 00:00:03,020
Hello World!

2
00:00:03,610 --> 00:00:06,017
That's a beauty!

Type CEA608/708 OP47

Embedded in a QuickTime 
media file

Supports a QuickTime Closed 
Captioning track, in CEA608 
or CEA708.

Not supported.

Embedded in a MXF media 
file

Supports a Closed 
Captioning track in CEA708

VANC packets with DID 0x43/
SDID 0x02

Sidecar file

Supports SRT files*. Output in 
SDI VANC is 608 packaged 
into 708, not full 708. So 
formatting and languages will 
be limited.

Supports SRT and STL file*

 

https://store.softron.tv/product_info.php?products_id=133
https://store.softron.tv/product_info.php?cPath=45_27&products_id=33
https://store.softron.tv/product_info.php?products_id=133
https://softron.zendesk.com/hc/en-us/articles/360017753759-HOW-TO-Do-Closed-Captioning-with-OnTheAir-Video-4
https://softron.zendesk.com/hc/en-us/articles/360017753759-HOW-TO-Do-Closed-Captioning-with-OnTheAir-Video-4
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There is one strict limitation. The length of the line must be of maximum 34 characters, so if 
you need to align your text on the right, you must format it this way: 

1
00:00:18,220 --> 00:00:20,360
                       Hello World
              Aligned to the right

You can add a few formatting options, such as the color: 
1
00:00:00,980 --> 00:00:03,020
<font color="FFFF00">Hello World</font>

Here are the supported colors and their corresponding codes: 

And you can use the "{\anX}" tag at the beginning of a line to define the position of the 
subtitling, where you replace the "X" by a digit from 1 to 9 corresponding to the position of 
the touches on a numeric keypad. (so for example 1 = Bottom Left, 9 = Top Right, etc...): 

1
00:00:00,980 --> 00:00:03,020
{\an9}Shown at the top right

And here are the positions and their corresponding tags: 

10.2.2.Burn a SRT file in your playout 
 
If your clip as a SRT file as a sidecar ( the 
two files have the same names in the same 
folder). You can overlay (burn the captions) 
on the video output. To do that, go the top 
menu “OnTheAir Video > Settings > 
Captions”.  

You can also set the Font, the size of your 
Captions and the size of the Stroke Width. 

White:     FFFFFF Yellow:   FFFF00 Cyan:      00FFFF

Red:        FF0000 Blue:       0000FF

Green:    00FF00 Purple:   FF00FF

Bottom Left:           {\an1} Middle Right:         {\an6}

Bottom Center:      {\an2} Top Left:                 {\an7}

Bottom Right:        {\an3} Top Center:           {\an8}

Middle Left:            {\an4} Top Right:              {\an9}

Middle Center:      {\an5}
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10.3. Supported Characters  

In the "NTSC world" (formats using 29.97fps and 30fps), when we output subtitle to SDI, we 
format it as CEA-608 packaged into CEA-708. This means that not all characters will be 
supported. When creating your subtitle make sure not to use any special character. In any 
case, the best is to test with our free demo version, and see if the characters that you want 
to use are supported. Here's a non exhaustive list of characters that should be supported: 

Characters Specific to languages: All French and Spanish characters should be supported. 
Other languages are not, but this may change, so don't hesitate to run a quick test with our 
free demo versions to confirm. 

10.4. Creating Files  

You can embed CC tracks in QuickTime or MXF files. There are multiple ways to do this. 
Editing software have been more and more capable over the years. We have an article that 
explains the different workflows for closed Captioning (not for OP47). 

The options to create OP47 are more scarce. You can only embed OP47 in MXF files, not in 
QuickTime .mov files. But most editing software can export an SRT file that we can then 
read. So out of all the possibilities, the SRT file is what seems the most flexible, as many 
software support it, it can also be uploaded to YouTube or other streaming platform, and is 
easy to edit. But of course you will need to make sure that it always travels with the file. 

Alphanumeric Characters Basic Punctuation Special Characters

Capital letters (A-Z) Period (.) Ampersand (&)

Lowercase letters (a-z) Comma (,) Pound/Hash (#)

Numbers (0-9) Question mark (?) At symbol (@)

Exclamation mark (!) Dollar sign ($)

Hyphen (-) Percent (%)

Apostrophe (') Asterisk (*)

Plus (+)

Equal (=)

Semi-colon (;)

Colon (:)

Double Quote (")

Left and right parentheses 
( () )

Forward slash (/)

Backslash ()

 

https://softron.zendesk.com/hc/en-us/articles/360017759879-HOW-TO-Create-and-verify-QuickTime-video-files-with-Closed-Captioning
https://softron.zendesk.com/hc/en-us/articles/360017759879-HOW-TO-Create-and-verify-QuickTime-video-files-with-Closed-Captioning
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11. Remote Control  
Not available in OnTheAir Video Express. 
Remote control is possible with the demo version but not with the Media Browser remote 
(no cataloging in DEMO mode) 

To use this feature, you need the Remote Pack option for OnTheAir Video or the Traffic 
option for OnTheAir Video.  

The Remote Pack Option for OnTheAir Video enables the Remote Control of one or more 
OnTheAir Video instances over the network either via a simple web browser or via another 
unlicensed OnTheAir Video. It also adds a convenient Media Browser to allow you to add 
medias to your playlist remotely. 

11.1. Set Up the Playout Channel  

The playout is the OnTheAir Video where the Remote Pack option has been applied.  
On this computer, go to the top menu “OnTheAir Video > Settings > General > Media”. 
 
First, set your Media Folder:  
• Media Folder: it is a watch folder for 

OnTheAir Video where it finds the 
media that it has to play. Once you 
indicate such a Media Folder to 
OnTheAir Video, it scans the 
locations that you indicated and 
shows the list of media available to 
your application. 

Now, enable the Catalog Media 
Folder:  
• Catalog Media Folder: It will catalog 

and validate content from the Media 
Folder. It is essential if you want to 
use the Remote or the Traffic option. 

• Media Browser: An OnTheAir Video 
window that allows you to read 
content from a local or a remote 
Media Folder. More explanations in 
the chapter “Traffic option”  

  
• You can also set the default FPS (Frame Rate) for BXF segments to 29.97 or 59.94. 

BXF (Broadcast eXchange Format) allows the interchange of data and metadata among 
professional system. In OnTheAir Video it allows you to automatically create segments in 
the Media Browser.  

• You can choose to enable/disable the Drop Frame and to Override TC Info. 

 

https://store.softron.tv/product_info.php?cPath=45_27&products_id=247
https://store.softron.tv/product_info.php?cPath=45_27&products_id=230
https://store.softron.tv/product_info.php?cPath=45_27&products_id=230
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Now that you set the Media Folder and you enabled the Catalog Media Folder option, stay in 
the General Settings and go to the HTTP Server:  
Make sure to enable Remote Control, and you can change the options:  
• Server Name: the name that will be 

displayed when you'll try to connect to it 
• Port Number: is the port number that 

will be used to communicate with it. 
Depending on your FireWall 
configuration, you may want to change 
that, but otherwise leave it to the 
default value (8081) 

• Web Pages Folder: If you have created 
one or several web pages to interact 
with OnTheAir Video, you can select the 
folder containing those pages and it will 
be hosted by the application. For 
instance, a page called "Custom.html" in 
a folder selected could be reached at 
127.0.0.1:8081/Custom.html 

• Require Authentication: Where you can 
choose the users that have access to 
your OnTheAir Video…. You can add/
Remove them and also set a password. 

11.2. Remote Client 

The Remote client can be a simple web browser or another OnTheAir Video, even 
unlicensed. In this next example, we are working on a different computer and we will remote 
control the OnTheAir Video we just set before. 

First, go to the top menu “OnTheAir 
Video > Remote Control…”  

This window will appear:  

• Click “+” to add the playout channel 
to your list.  

• You can then assign a color.  
• Click on Connect…  
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When you are connecting to the playout channel, this window will pop: 

If Require Authentication was enable by the playout channel, put your Username and your 
Password. You can Save to Keychain.  
There is three Connection Types that determine the limits of your access to OnTheAir Video:  

• Media Browser Only: the Media Browser is the only window accessible. When enable, 
Local Validation allows you to validate or not a clip.  

• Playback Observe: You only observe the playout.  
• Playback Control: You have full control of the playout.   

11.2.1. Remote Control Playlists 

Now that the computer is connected, you can remote control the playout channel. Just 
below, you can see at the left a playlist from the playout channel and at the right, the same 
playlist and clips visible by the Remote client, 

The Remote Client can only show playlists that have been saved at least once in the Playout 
channel. Once a new playlist is saved, it will be shown as a new tab in the Remote Client:  

 

Remote 
Client

Playout
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With Remote Control, the Remote Client can control the playlist as if it was on his own 
computer. You can add or remove clips, play or stop the channel, go to the next clip… It will 
automatically affects the Playout Channel. Here’s an example of a playlist played using 
Remote Control: 

11.2.2. Remote Control the Media Browser 

On the playout channel, you can open the Media Browser (Available with the Remote 
Control option or the Traffic option). This window allows you to visualize the content of the 
Media Folder. It is also useful because there can be a link between the media browser and 
the playlists. 
It will be visible by the Remote Client just by opening the Source window. In there, you can 
access the clips from the Playout channel Media Folder.  

Everything about the Media Browser is explained in the chapter “Media Browser” 

 

 Note that you can control multiple OnTheAir Video on multiple Playout channels at 
the same time… You can find tutorials on our Youtube channel. 

https://www.youtube.com/watch?v=H6_uX9tgdts
https://store.softron.tv/product_info.php?cPath=45_27&products_id=247
https://store.softron.tv/product_info.php?cPath=45_27&products_id=247
https://store.softron.tv/product_info.php?cPath=45_27&products_id=230
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12. Media Browser 
Not available in OnTheAir Video Express. 
(Available with the Remote Control option or the Traffic option) 

The Media Browser allows you to visualize the content of a local or a remote Media Folder. It 
is also useful because there can be a link between the media browser and the playlists. You 
can change the Clip ID, add In and Out Point… Media Browser can also be used with the 
Traffic option, as playlists coming from Wide Orbit do not have any information on the path 
to access the media, it is needed that the user selects a folder where the media will be. 

12.1. How to Set it Up 

You can either use a "Local" or a "Remote" media browser. Sometimes you want to limit the 
number of things that the computer playing out is doing. This is why instead of having it 
catalog the media, you can offload the media cataloguing to a separate, remote, computer. 
Note that this makes the setup a little more complex, so if you want to keep things simple, 
just use a local media browser. 

12.1.1. Set Up a Local Media Browser 

Choose the folder where all your videos will 
be, go to the top menu “OnTheAir Video > 
Settings > General > Media" and select a 
folder here: 

If you are using a local media browser, make 
sure to leave the "Catalog Media Folder" 
enabled. You should disable the Media Folder 
catalog only if you are using a remote media 
folder. Note that all files should be within the 
same folder, it is best not to use subfolders. 
  

12.1.2. Set Up a Remote Media Browser 

Before being able to setup a remote Media Browser, you will first need to setup one of your 
other computers as a "Local Media Browser" so it will catalog the media. Note that this can 
be done using a demo version of 
OnTheAir Video. 
Then you will need to connect to 
that OnTheAir Video. For this, go to 
the menu "OnTheAir Video > 
Remote Control...". This will open a 
window, where you will be able to 
connect to a remote OnTheAir 
Video: 

 

https://store.softron.tv/product_info.php?cPath=45_27&products_id=247
https://store.softron.tv/product_info.php?cPath=45_27&products_id=230
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Once it is setup, and you are connected 
to the OnTheAir Video doing the media 
folder cataloging, make sure to disable 
the "Catalog Media Folder" option on 
the playout computer, so you are sure 
OnTheAir Video will not catalog any 
folder, and then select the remote media 
browser you want to use in the "Media 
Browser" drop down menu: 

12.2. How does it Work 

Once you have set the local or remote media browser that you want to use, you can go to 
the menu "Window > Media Browser" to show the Media Browser window: 

You can view the different columns: 

• Clip ID: by default 
the "File Name". As 
these are usually 
codes, it is not 
easily readable. 

• Description: is 
something 
humanly readable 
and can be edited 

• In/Out Points and 
Duration 

  

12.2.1. Changing In/Out Points or Attributes 

You can change in/out points directly in the Media Browser. For that, enable the checkbox 
next to the in or out point and manually enter a value there. But note that there are no 
validations for example with the duration of the clip. So the better option is probably to do it 
in the inspector. 
To change the clips attributes in the inspector, select the clip in the Media Browser, then 
open the inspector from the menu "Window > Clip Inspector". Anything you set there will be 
saved in the Media Browser, so when you drag and drop from the Media Browser to the 
playlist, everything you have set will be there.  
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12.3. The Link with Playlists 

In some cases, there can be a link between the Media Browser and the playlist, so if 
you modify the clips attributes (in/out, name, actions...) in the media browser, they will be 
updated in the playlist. This is very useful to be able to modify a clip that is present in 
multiple playlists, or has multiple occurrences in the same playlist. 
The link happens in two cases: 

• if you drag and drop a clip from the media browser to one or more playlists 

• if you open a .WOS playlist from the traffic (Go to chapter “Traffic option”) 
 

12.3.1. How to Identify if a Clip in a Playlist has a Link to the 
Media Browser? 

In the playlist: 
You will see that the first line of the cell is 
bold compared to other clips not linked to 
the Media Browser. 

• The bold part is the "Clip ID" from 
the media browser 

• The plain part is the "Description" 
from the media browser 

Note that if Clip ID and Descriptions are identical, we will only show one occurence in bold. 
  
In the inspector: 
At the top of the window, you will see an area with 
the Clip ID: 
You can use the cross to remove the link to the 
media browser (the clip in the playlist will thus be 
independent), and the magnifying glass to reveal 
the clip in the Media Browser. 

12.3.2. How can the Link be Lost? 

The Clip ID is what we use to make the link between the clips in the playlists and the clips in 
the Media Browser. So if you modify the Clip ID in the Media Browser, you will loose the 
connection. 
  

 

The link is only in one direction: from the Media Browser to the playlists. If you 
modify a clip in the playlist, it means there will be a difference between the 
attributes in the playlist and the ones in the Media Browser. That is not a problem, 
but as soon as you'll edit one attribute in the Media Browser, all the attributes in the 
playlist will be reloaded with the ones from the Media Browser.
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13. External Controls and Integration 

With its flexible system of "Actions", OnTheAir Video can send SCTE35 triggers, overlay 
dynamic graphics (with the DGO option), control multiple external devices such as Character 
Generators, video routers, logo inserters. Actions can be triggered at any moment of a clip 
within a playlist. Actions are AppleScripts, so it is very easy to customize them and create 
macros to perform multiple controls with a simple action. 

13.1. Working with Actions (Secondary Events) 
Not available in OnTheAir Video Express. 
 

An Action in OnTheAir Video is a what is sometimes called "Secondary Event". The 
secondary event can be happening in OnTheAir Video itself, or outside of OnTheAir Video. 
This is what allows you to, for example: 

• In OnTheAir Video: 
> Control a project of the Dynamic Graphics Overlay (Requires the DGO option): 
start/stop a ticker, lower third, clock. Or modify a text item, image or video link... 
etc... Read more... 

> Control a video router: change crosspoints on a Blackmagic-Design VideoHub or 
Ross router.  

> Output a SCTE trigger (Requires the CC option): send a SCTE35 trigger an the SDI 
output. Read more... 

• Outside of OnTheAir Video: 
> Control a project in OnTheAir CG Server: start/stop a ticker, lower third, clock. Or 
modify a text item, image or video link... etc... Read more... 

> Change the status of the outputs of GPICommander 

> Start/stop recording in MovieRecorder. 

> And many more things. As an action is an AppleScript, you can basically control any 
application that is AppleScriptable... even send an email for example. 

 

 This chapter pertains to OnTheAir Video 4.2 or later, if you are using version 4.1 or 
earlier, check this article. 

https://store.softron.tv/product_info.php?cPath=45_27&products_id=117
https://softron.zendesk.com/hc/en-us/articles/4401882454546-HOW-TO-Use-the-DGO-option-of-OnTheAir-Video
https://store.softron.tv/product_info.php?cPath=45_27&products_id=133
https://softron.zendesk.com/hc/en-us/articles/360017761919-HOW-TO-Trigger-SCTE-35-SCTE-104-with-OnTheAir-Video-4
https://softron.zendesk.com/hc/en-us/articles/215330478-HOW-TO-Control-OnTheAir-CG-Server-from-OnTheAir-Video
https://softron.tv/products/record/movierecorder
https://softron.zendesk.com/hc/en-us/articles/5642545714972


-  -54

OnTheAir Video User Manual

13.1.1. Adding Actions  

To add an action, select a clip in your playlist, then show the Inspector and select the 
"Timeline" pane.  

To add an action on a clip, first scrub in the 
preview above at the moment you want the 
action to be triggered and then click on the + 
icon. This will create something like this: 

 
With the following info: 

• The checkmark/cross: tells if there is a 
problem with the Action. If you see a 
cross there, check the "possible errors" 
section below. 

• Position: is the moment at which the 
action will be triggered. Make sure to 
check the "Relative to" column. The 
"Relative positions" are explained 
below. 

• Actions/Parameter: There you will 
select the action that you want to do, 
and its parameters. See below for the 
different types of actions. 

13.1.2. Adding Actions  

An Action can be triggered at any moment of a video file. You can then select wether you 
want that the position value shown is "relative to": 

• Before Start: This happens when clips are chained and we prepare the next one. This 
allows to control video routers in a clean way. It usually happens 8 seconds before the 
next clip. If the clip is not playing in chain, but you force to start it (if you double-click, 
press play, etc...), we will wait for 1 second to receive the confirmation that the action 
was successfully performed. Typical usage: When controlling a video router, this 
allows for the switching action to be completed before we start playing a live 
(otherwise you would see a few flash frames at the beginning). 

• Start: The position indicated is relative to the beginning of the clip, whatever in point 
is set. This is the kind of action that will never move depending on the in point. So it 
means that if your in point is after the action position, it won't be triggered. A Red 
Cross will show up in such cases. Typical usage: this type of position is used for lower 
third for example, where you want a lower third graphics element to be played at the 
exact position, whatever the in point of the clip may be. 

• In Point: The position indicated is relative to the in point. This means that the action 
will move depending on the in point that you set. If no in point is set, the position will 
be relative to the start of the clip. Typical usage: this is used if you want an action to 
be triggered all the time at the beginning of the clip, or after 20 seconds for example, 
and this whatever the in point may be. 
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• Out Point: The position indicated is relative to the out point. This means that the 
action will move depending on the out point that you set. If no out point is set, the 
position will be relative to the end of the clip. Typical usage: this is used if you want an 
action to be triggered all the time at the end of the clip, or 20 seconds before the clip 
stops playing for example, and this whatever the out point may be. 

• End: The position indicated is relative to the end of the clip, whatever out point is set. 
This is the kind of action that will never move depending on the out point. So it means 
that if your out point is before the action position, it won't be triggered. A Red Cross 
will show up in such cases. Typical usage: this type of position is used for lower third 
for example, where you want a lower third graphics element to be played at the exact 
position, whatever the out point of the clip may be. 

13.1.3. Going To / Moving Actions 

When you select an action you can click on any of these two buttons: 

• Go To Action Position: will move your playhead to where the action will be triggered. 

• Move Action To Current Position: will change the position value to match the current 
position, and "relative to" setting. Note that you can also enter a TC value manually in 
the Position column. 

13.1.4. Types of Actions 

At the time of writing (but we'll add more over time), here are some of the ones that we 
support: 

• ATEM: Change the input used as program output, with or without transition (will do a 
TAKE or a CUT) and Start a macro 

• AppleScript: (see below) 

• GPI: Trigger a GPI output (Pulse, On or Off). Make sure to select the GPI to use in 
"Settings > Triggers > GPI Commander" 

• Graphics: Start/Stop a project of the Dynamic Graphics Overlay option. Configure this 
in "Settings > Graphics" 

• MIDI: Output a note or other to the MIDI device selected in "Settings > Triggers > MIDI" 

• Playback: Performs playback actions, such as play next clip, stop playback, pause.  

• Routers: Control video routers from Ross Ultrix or Blackmagic-Design Videohub 

• SCTE: Trigger SCTE-35 events on the output 
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Depending on the type of action you have selected, you will see different icons in your 
playlist: 

Once you have selected your action, 
you can edit its parameters. For each 
parameter, you will also see a "After 
Delay (ms)" option. This allows you to 
define a delay between the moment 
the action is triggered and when it is 
effectively triggered. This is useful if 
you have an action running at the 
start of a clip, but need to delay a 
little bit the action before it's actually 
done. 

13.2. Control with AppleScript Actions 
Not available in OnTheAir Video Express. 

Before OnTheAir Video 4.2, the only actions available were AppleScripts. It is still possible to 
use these AppleScripts in OnTheAir Video 4.2 and they work the same way. 

13.2.1. How to create the AppleScripts? 

They must be formatted in a certain way. Basically all you have to do, is to add an "On 
Action" at the beginning, and "End Action" at the end of the script, so it would look like this 
(to play a DGO project in OnTheAir Video): 

on action(Parameter) 
    tell application "OnTheAir Video" 
        tell project "LowerThird" 
            play 
        end tell 
    end tell 
end action 

Note that the "Parameter" variable is what can be sent from OnTheAir Video. So you can 
write one script, and do different things depending on what you set in the "Parameter" field 
in the OnTheAir Video inspector. 
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We have sample AppleScripts that you can download, and you should start from there. 
Check this articles above which provide you some sample AppleScripts. Don't hesitate to 
contact us if you have questions. While we won't be able to write all the AppleScripts for 
you, we can give you some recommendations. 

13.2.2. Where should I save these AppleScripts? 

Actions should be placed in the following folder (if using OnTheAir Video):  

/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video/
Actions 

If you are using the "multi" version of OnTheAir Video, there will be one folder per “channel": 

/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video 1/
Actions 
/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video 2/
Actions 

13.2.3.  About the AppleScript Authorization 

When working with AppleScripts, and controlling other software, macOS sometimes requires 
you to authorize the script to control the software, for obvious security reasons. If you don't 
authorize it beforehand, macOS will show a warning the first time the script is executed. As 
this can cause issues during production, we have added a way to force the authorization.  

For this, go in "OnTheAir Video > Settings > Actions", you will see the list of Actions that you 
have saved in the Actions folder explained above and a "Authorize" button next to it. What 
this will do is that it will execute the script, so you may want to be careful with this, and 
maybe have one "authorization" script that will not actually do anything… 

13.2.4.  Possible Errors or Warnings 

There are two possible errors or warnings on 
a clip: 

• A Red Cross: means that the action will 
not be triggered. Either because for 
example an in point has been set and 
the action was before that in point, or 
there is another error such as an 
AppleScript file that is missing. 

• A Yellow Arrow: means that the action 
will be triggered, although it was set just 
a little bit before the in or after the out 
point, but we have a tolerance that will 
force it to be triggered. 

When you see a Red Cross or the Yellow Arrow before an action, hover with your mouse on 
the warning, and you should see the explanation. 
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13.3. Control using the REST API  
Not available in OnTheAir Video Express. 

OnTheAir Video can be controlled using a REST API. OnTheAir Video uses port 8081 for the 
REST API. 
If you are using a "multi" version of OnTheAir Video, the port numbers will change: 

• 8081 is for OnTheAir Video 1 

• 8082 is for OnTheAir Video 2 

• 8083 is for OnTheAir Video 3 

• etc… 

13.3.1. Retrieve the API from the Application 

Then the best way to get the most up to date documentation for the OnTheAir Video REST 
API is to start the OnTheAir Video application on a Mac, and then simply type in a browser 
on that Mac: 

http://localhost:8081/api.html 

This will return a page with all the API documentation.  

13.3.2.  About Websockets 

We have websockets in OnTheAir Video so you can be notified when something changes. 
You should be able to open a websocket for timecode update about playback with this URL:  
ws://localhost:8081/playback 

It is also important that, when you connect, you provide the correct supported protocols as 
we will only send messages to clients who support our protocols. 
Below is the list of the protocols we support BUT it is also important that you connect to a 
specific endpoint. For instance, if you want updates on a specific playlist, you will need to 
open a websocket at: ws://127.0.0.1:8081/playlists/<playlist unique ID> 

• "playback_update_v1"                                    // playback status is changing  

• "playlist_update_v1"                                        // a specific playlist changes  

• "playlists_management_v1"                            // playlists are being open/closed 

• "playlist_items_start_times_update_v1"       // item start times inside a playlist  

• "live_sources_update_v1"                               // live sources change 

Attached is a sample page so you can get started: websocket_client_2.html 

 

http://localhost:8081/api.html
https://softron.zendesk.com/hc/en-us/article_attachments/6808964493212
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13.4. Using the Stream Deck Controller  
Available in OnTheAir Video Express only with the built-in integration, or in Bitfocus 
companion only through the HyperDeck Emulation.  

OnTheAir Video can be controlled simply using a Stream Deck from Elgato. Different options 
exist :  
• Use the integration that we have built in our software, 
• Or use the Bitfocus Companion and either: 

	 	 - Some Companion "Modules" 
	 	 - Our RESTfull HTTP AP 
	 	 - The HyperDeck Emulation 
• Or use the software that Elgato is providing, 

It will be one or the other.  

13.4.1. Softron Integration 

First, start your Softron application. Depending on the application that you use, you will have 
different layouts.  
If you go to the menu "Window > Show Stream Deck window", you should see a window 
such as this one: 

There are two sections in the window: 
• To the left is the list of available pages, with their names and which kind of Stream 

Deck device they are for. 
• To the right is the list of Stream Deck devices that are connected to your computer. On 

the screenshot above, there is a "Classic" and a “Mini” 

As we wanted to allow you to select which device you want to use for each application. 
Before you can start using your Stream Deck, you have to drag and drop at least one page 
from the list on the left on to one of the device on the right.  

 

https://bitfocus.io/companion/
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You can also decide to enable the "Hold" option. This option is important for two things: 

• if you want to be able to trigger your Softron application, even when using a different 
application 

• if you are using multiple Stream Decks and you want each to use a different 
application 

13.4.2.Customizing the Pages 

You can create new pages by clicking on the “+” icon at the 
bottom of the pages list: 
Each page can also be modified. For this, right-click on any of 
the page, and select "Edit": 
Or you can click on the triangle. 

When you are editing a page, you will see the device in big, with the list of possible actions 
on the right: 

  
You can drag and drop actions from one button to another to move them, or from the list to a 
button. Click on "OK" when you are done.  
 

 

In order to be able to use the Softron integration, you need to make sure that the 
"Stream Deck" software is not running. If it is running, it will prevent us to access 
the Stream Deck. So make sure that it is not set to automatically launch at startup. 

If you need help, check our webpage explaining how to use a the Stream Deck 
Controller

https://softron.zendesk.com/hc/en-us/articles/360015242494-HOW-TO-Use-Elgato-s-Stream-Deck
https://softron.zendesk.com/hc/en-us/articles/360015242494-HOW-TO-Use-Elgato-s-Stream-Deck
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13.4.3. Customizing the List of Actions 
	 	  
In the edit window, you can create a new action by clicking on the + icon at the bottom of 
the list. You can also select an action, right click and select either "New" or "Duplicate" (note 
that you can not edit the default actions). 

After a new action is created (or duplicated), click on the "wheel" icon to edit it (or right-click 
and select "Edit"). This should open a window: 

 
You can set: 

• Name: This is the name displayed in the list 

• Selector: This is the "action" that will be made. We recommend that you duplicate an 
existing action and then edit the parameter, as all possible actions are listed in the list, 
there are no other. 

• Parameter: Only certain actions support a parameter. This is true for example in 
OnTheAir Video to start playing a specific clip. 

• Enabled Image: It's the image that is used when the action is not active. 

• Active Image: It's the image that is used when the action is active. For example if a 
source is recording in MovieRecorder.  

13.4.4. Restore to Defaults  

The "Restore to defaults" button can be used if you want to 
restore to the default configuration. 
Note that this can be useful also if you want to use new 
features or buttons that were done in a new version of the 
application. It will also copy the new images to the folder. 
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13.4.5.Bitfocus Companion 
	 	  
First you will need to download the application from Bitfocus's website. Once installed, start 
it, and click on the "Launch GUI" button. 
Then a few questions will be asked to do the setup, we suggest that you check the 
documentation online to set it up the best way to match your needs. In this case, use a 
module for OnTheAir Video.  
 

	 	 	 13.4.5.1. Using a Module 

To control OnTheAir Video with Bitfocus, you will 
need to find the IP address of the computer 
where it runs (check the network settings) as well 
as the port number. You can find the different 
port numbers either in the articles in our help 
center, or simply by checking the settings of your 
application. 

• Once you have done the first steps of your 
setups, in the "Connections" tab of Companion, 
search for "Softron" to show all modules 
available. 

• Click on "Add" next to the module you want to use. 

• Then configure: 
	 The Label = how it will be shown in the Companion settings 
	 Target IP = the IP address of the computer where your Softron application is running 
	 Target Port = the port number used by your Softron Application.  
Once this is setup, you should see that the Status is now “Connected”. 

 

https://bitfocus.io/user/downloads
https://softron.zendesk.com/hc/en-us/sections/201275207-Information-for-third-Party-Integration-Restricted-
https://softron.zendesk.com/hc/en-us/sections/201275207-Information-for-third-Party-Integration-Restricted-
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Now go to the "Buttons" pane, 
where you will now see the 
Presets for MovieRecorder. 
Click on the red button, to 
show the different types of 
actions. you will see the 
different "Presets" available to 
control OnTheAir Video. You 
can now drag and drop these 
on buttons to assign them: 

That's it, the buttons should now show up on your Stream Deck. If you want to emulate on 
your computer, you can click on "Web buttons" in the left list. 
Of course there is more to it, you can then also edit the preset buttons, as these are just 
preset, you can modify them to your liking… 

	 	 	 13.4.5.2. Using the REST API 

If you want to do actions not available in the OnTheAir Video modules, you can use our 
REST API. you can find some information about our REST API on our support desk. If you 
need more info, don't hesitate to get in touch with us. 
All the steps are explained in our online article.  

13.4.6. StreamDeck Application 

We won't go into too much details, as you can find a lot of info on Elgato's website or on the 
web about this, but the idea is that you should first download and install the Elgato Stream 
Deck software. 
Again if you use the Softron integration, you should NOT start the Stream Deck software as 
it will prevent us to access the Stream Deck. It can be present on the computer, but not 
running. 
Once installed, you will be able to configure the buttons. 
For an integration with the Softron software, you will have to either: 

• Send REST requests. 

• Emulate keyboard shortcuts (you will have to know the keyboard shortcuts that you 
can use in our application). 

The advantage of the keyboard shortcuts, is that it's way easier to do, but the downside is 
that you will have to make sure that the application is the front application for the keyboard 
shortcut to work. If it's not the front application, the keyboard shortcut might do something 
different. The REST requests are a little harder to setup, but will work wether the application 
is front or not. All the steps are explained in our online article. 

 

https://softron.zendesk.com/hc/en-us/sections/201275207-Information-for-third-Party-Integration-Restricted-
https://softron.tv/about/contact
https://softron.zendesk.com/hc/en-us/articles/360015242494-HOW-TO-Use-Elgato-s-Stream-Deck
https://gc-updates.elgato.com/mac/sd-update/final/download-website.php
https://softron.zendesk.com/hc/en-us/articles/360015242494-HOW-TO-Use-Elgato-s-Stream-Deck
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13.5. Control with GPICommander 

GPICommander is two things: a USB to GPI Converter and a 
software. You can send or receive GPI triggers using 
AppleScript. 
It has 24 inputs (open-collector type, common 
ground) and 8 independent relay outputs but since 
each unit has a unique serial ID, you can chain more 
than once on the USB bus to have more inputs and/or 
outputs. 

13.5.1. Connecting the GPICommander Box 

You will need to: 

• Connect the GPICommander device to the computer where OnTheAir Video is 
running. 

• Connect the GPICommander's inputs to your device (it can be a production switcher 
GPI/tally output or a simple push button box) using the DB25 connector. Check the 
dedicated User manual for instructions on how to connect it. 

 
With OnTheAir Video you will mainly use 
the inputs. These 24 inputs are 
available through a DB25 connector, 
where basically and very briefly, an 
action will be triggered in OnTheAir 
Video when any of the first 24 pins 
is connected to the "ground" (on pin 25). 

13.5.2. With the Direct Integration or AppleScripts? 

To control OnTheAir Video with GPICommander, you have two options: 

• with the direct integration: you just have to connect the GPICommander box to the 
computer and go to the Settings of OnTheAir Video to set it up. This is the easiest 
way. This works with OnTheAir Video and OnTheAir Video Express. 

• with AppleScripts. This requires you to know how AppleScript work, as well as 
installing the software GPICommander but offers a lot of possibility. For example, you 
could control multiple applications with just one GPI trigger. This works only with 
OnTheAir Video as OnTheAir Video Express can not be controlled with AppleScripts. 

13.5.3.  Use the Direct Integration 

Open the the OnTheAir Video settings, and select the GPICommander to be used in the top 
left drop down menu. You can connect multiple GPICommanders to one computer, but only 
use one in OnTheAir Video. They will be listed with their serial numbers. 

 

https://store.softron.tv/product_info.php?products_id=28
https://softron.tv/resources/user_manuals/GPICommander2_QuickStart.pdf
https://store.softron.tv/product_info.php?products_id=28
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Once you have selected the 
GPICommander to use, select the type 
of behavior that you want in the "As" 
drop down menu.  
You can decide for three types of 
usage: 

• As Remote Controller (more for 
generic uses) 

• As Video Switcher (specifically 
when used with a production 
switcher) 

• As multi-usage (More advanced 
type that adds playback 
controls, graphics, SCTE… 
Inputs)  

	 	 	 13.5.3.1. GPICommander “As Remote Controller”  

When you select to use GPICommander "As Remote Controller", you will be able to set 2 
type of things: 

• Input Actions: set the action to be performed when a given GPI input is triggered 

• Tally Outputs: set the output to put on on depending on the status of OnTheAir Video  

Input Actions: 
You will see there a list of different actions that can be 
performed. For example the "Play Selected Clip" action 
when triggered will start playing the selected clip in the 
"Front" playlist. You must then define which input should be 
monitored. For that clip on the popup menu next to the 
action. 
Select for example "In 1". In that case, as soon as the input 1 
of the selected GPICommander turns to on, the selected 
clip in the from playlist will start playing. 
You can configure all actions like that. They are quite "self 
explanatory". The only things to note are: 

• if no clip is selected, then the action will be done on 
the first clip in the playlist 

• the "Space Bar" action will mimic the behavior done when you use the "Space bar" on 
your computer. This can be quite useful for cue mode, etc… 

Tally Outputs: 
There are two kind of status that can be monitored: 

• Playing: when OnTheAir Video is playing a clip, the selected output will be put to on. 

• Paused/Cue: When OnTheAir Video is paused or cued, the selected output will be put 
to on. 
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	 	 	 13.5.3.2. GPICommander "As Video Switcher" 

When you select to use GPICommander "As Video Switcher", the behaviors will be different, 
and is mainly used when GPICommander is connected to a Production Video Switcher. It is 
not mandatory, and you can use the "As Remote Controller" mode when connected to a 
Production Video Switcher, but basically the behaviors here will be identical to the ones 
when using an "ATEM Switcher". 
You will have two settings: 

• OnTheAir Video Input 
• Cue next clip when "OnTheAir 

Video Input" goes off-air 

The behavior will be as follows: 

• as soon as OnTheAir Video sees 
that the monitored input goes to 
on (it is then in use on your 
production switcher), it will start 
playing the selected (or cued) clip 
in the front playlist 

• then when the monitored input 
goes back to off (it is not in used 
anymore on the production 
switcher), and if the "Cue next clip 
when OnTheAir Video Input is 
deselected" option is enabled, we 
will automatically cue the next clip. 

	 	 	 13.5.3.3. GPICommander "As Multi-Usage“ 

GPI Triggers become more clever with 
the Multi-Usage option. This allows the 
operator to trigger SCTE, graphics, 
playback controls, and even 
ApplesScripts all from a GPI Commander 
device. Parameters are easily adjusted 
and assigned, and change parameters 
based off the category.  
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13.5.4.  Trigger AppleScripts when Inputs State Change 

As explained above, note that this will only work with OnTheAir Video and not with OnTheAir 
Video Express. 

With GPICommander, you can trigger an AppleScript when the state of any of the 24 input 
changes. You can trigger an AppleScript when the state changes from closed to opened or 
from opened to closed. These AppleScripts can control any application on the Mac that is 
AppleScriptable (and OnTheAir Video is AppleScriptable). 

For this you will need to download the GPICommander application from our website. This is 
the application that will trigger the AppleScripts. 

Read more about how to trigger AppleScripts from GPICommander in our website article. 

	  

Our GPI commander available on our website shop.  

 

http://softron.tv/downloads
https://softron.zendesk.com/knowledge/articles/115002594014/en-us?brand_id=1102326
https://softron.tv/products/hardware/gpicommander
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13.6. Control Macros on the ATEM 
Not available in OnTheAir Video Express. 

To make this work, go to the top 
menu “OnTheAir Video > Settings 
> Triggers > External Triggers”, 
and select to use the ATEM and 
enter an IP address. 
Also make sure to select "None" 
for the "OnTheAir Video Input" 
drop down. If you leave an input 
selected there, it will start playing 
in OnTheAir Video every time that 
input is selected (Unless that is 
what you want of course…). 

Attached is a sample AppleScript 
that you can use as an action in 
OnTheAir Video. We will use the 
name of the Macro in the ATEM in 
the script.  
OTAV_RunATEMMacro.scpt 

13.7. Control CG Projects from the Actions 
Not available in OnTheAir Video Express.  
You will need the DGO option.  
See explanations about the Dynamic Graphics Overlay option for OTAV in chapter: Graphics.  

When you change the status of the items attributes in the clip inspector, this value is applied 
for the whole duration of the clip. This is very nice and easy to use for projects that run for 
the whole duration of a clip. 
But if you want to start the project at a specific timecode in your clip, and have the same 
project play multiple times during a clip, but with different text or images overlay, you will 
need to use Actions.  

 

https://softron.zendesk.com/hc/en-us/article_attachments/5363463635730
https://store.softron.tv/product_info.php?products_id=117
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13.7.1. Using "Direct" Actions 

With OnTheAir Video 4.2, we have 
introduced new ways to trigger actions, 
make sure to read this article. When 
using "Direct Actions", you can use the 
"Graphics" type of actions, which allow 
you to start/Stop a project. 

Once you have selected the action 
type, click on "Parameters..." to select 
the project you want to start or stop. 
At the time of writing it is not yet 
possible to modify the content of text 
fields for example, or control items 
within projects. To do that you will still 
need to use "AppleScript" Actions. 

13.7.2. Using "AppleScript" Actions 

AppleScript actions can be used with all versions of OnTheAir Video. These were the only 
actions possible before OnTheAir Video 4.2. 
Attached to this article you will find a CG project and a sample Action. The CG project, you 
can place it wherever you want, just import it in the Settings as explained above. As for the 
Action, it should be placed in the following folder (if using OnTheAir Video):  

/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video/
Actions 

When the action is imported in the correct folder, go in the clip inspector > Timeline and 
scrub in the timeline to select when you want to CG project to start playing and click on the 
“+” icon to add a new action at that position.  
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13.8. Trigger SCTE Signals 
Not available in OnTheAir Video Express. 
You will need the CC option. 

SCTE signals are used to trigger markers downstream of the SCTE broadcasting source. 
These markers are used to signal an inline insertion opportunity for devices downstream 
such as commercial breaks or alternative programming. A daily example of this would be 
watching major television network's primetime programming. When a local commercial 
opportunity is available during network programming, a SCTE message is sent to the local 
broadcaster with identifiers and data like event id and duration. Then the local broadcaster's 
commercials will playout and return back to the main program.  

13.8.1. Difference between SCTE 35 and SCTE 104? 

• SCTE 104 applies only to SDI baseband video (in the VANC) 
• SCTE 35 applies to transport streams (compressed video) 

13.8.2. Requirements 

To trigger SCTE (35 or 104), you will need: 

• Either the free DEMO version of OnTheAir Video 4, or if you use a valid license of 
OnTheAir Video 4, you will need the CC option,  

• A video device that supports to output VANCs (all recent cards that we support and 
that have a SDI output should work fine, but older models of Blackmagic devices may 
not support it). Note that for AJA cards, you need to enable VANCs in AJA Control 
Panel. 

Note that we write the SCTE info in the VANC of an SDI output, so this will only work with an 
SDI output. When using the direct link (for example to send video from one of our playout 
application to another), the SCTE info is preserved. 
There are two ways to trigger SCTE: 
• With the SCTE trigger embedded in an MXF file 
• With an Action on OnTheAir Video. 

13.8.3.  SCTE embedded in an MXF File 

You can embed the SCTE info in a MXF file containing special VANCs of DID 0x41 and SDID 
0x07. Those triggers will be passed on to the SDI output signal. 
The advantage of this solution is that the SCTE trigger will always follow the video file. There 
will be nothing to do, but it may be complex to generate. 

13.8.4.  SCTE using Actions 

In OnTheAir Video 4.2 or later, actions can be more than just an AppleScript. You can still 
use the AppleScript that you were using in OnTheAir Video 4.1 or earlier, but additionally you 
can create "Direct" actions which do not go through AppleScripts.  

 

https://store.softron.tv/product_info.php?products_id=133
https://store.softron.tv/product_info.php?cPath=45_27&products_id=33
https://store.softron.tv/product_info.php?cPath=45_27&products_id=33
https://store.softron.tv/product_info.php?products_id=133
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Just select the SCTE trigger type in the "Inspector > Timeline > Actions" section. 
Then click on "Parameters..." to edit it. 

• Splice types: Depending on the command to be sent, the "splice_insert_type" property 
can have a value of: 

> splicestart_normal 
> splicestart_immediate 
> spliceend_normal 
> spliceend_immediate 
> splice_cancel 

Please see SCTE documentation for the various splice commands. 
• Event ID: You can set the event ID. If it is not specified, it will be automatically incremented, 

starting at zero when the application starts. 
• Program ID: You can set the ID in the Program.  
• Duration (ds): You can also send the duration of the event, simply by adding a duration, 

expressed in deciseconds (so if you indicate 10 it is 1 second). 
• After Delay (ms): You can set a delay in milliseconds (ms) before the SCTE is actually 

triggered. This will compensate for potential delays in your output chain. 
If you need more help, we have a tutorial in our Youtube Channel with the video: How to 
Trigger & View SCTE with Softron Products 

13.9.  Create Playlists from Third Party Solutions 

There are a number of different ways to create playlists for our playout applications. These 
playlists can be opened or imported by either OnTheAir Video, OnTheAir Video Express, 
OnTheAir Manager or OnTheAir Live 
You have mainly two choices: 

• .txt files: this is the easiest solution, but you will only be able to add clips. You won't be 
able to set a logo, add in/out points, etc... for that you'll have to create XML playlists 

• XML: this is more complex, as you need to know how to generate XML files. But this is 
the most flexible solution as you can really set everything that you would set in the 
OnTheAir Video playlists: set the playlist in loop, add logo overlay, add audio gain, 
etc… 

Everything is explained in our website article: “HOW TO: Create OnTheAir Video playlists 
from third party solutions?” 

 

https://www.youtube.com/watch?v=o730aydhm4k
https://www.youtube.com/watch?v=o730aydhm4k
https://www.youtube.com/watch?v=o730aydhm4k
https://softron.zendesk.com/hc/en-us/articles/207696757-HOW-TO-Create-OnTheAir-Video-playlists-from-third-party-solutions
https://softron.zendesk.com/hc/en-us/articles/207696757-HOW-TO-Create-OnTheAir-Video-playlists-from-third-party-solutions
https://softron.zendesk.com/hc/en-us/articles/207696757-HOW-TO-Create-OnTheAir-Video-playlists-from-third-party-solutions
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13.10. Control a Video Router 
Not available in OnTheAir Video Express. 

The compatible routers for this feature are Blackmagic Videohub and Ross Ultrix. For other 
routers, you can still use OnTheAir Switch, check compatibility here. Or Alternatively, you can 
use a curl request to control routers such as the AJA Kumo (sample AppleScript attached). 

13.10.1.  How to Set it Up? 

There is no preference to add in OnTheAir Video, but just add an Action (AppleScript) to the 
"Actions" folder of OnTheAir Video. 
If you are using the "single" version of OnTheAir Video, the Actions folder is located in: 

/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video/
Actions/ 

If you are using the "Multi" version, then it will be in each instance folder: 

/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video 1/
Actions/ 
/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video 2/
Actions/ 
/Library/Application Support/Softron/OnTheAir Video/OnTheAir Video 3/
Actions/ 
… 

13.10.2. How to use the Script Alone or test it? 

The examples below are to be used as "Actions" in OnTheAir Video. But If you want to use 
the AppleScript from another application, or test them alone, you will need to remove the 
first (on Action(parameter)) and last (end Action) lines.  

13.10.3. With Blackmagic Video hub 

There are two different syntaxes possible: Using the “Switch Videohub” method or using 
the set selected input method.  

	 	 	 13.10.3.1. Using "switch Video hub" Method 

The simplest method is to do a "switch videohub". You can use either the IP address, the 
name or the unique id of the Videohub. Using its IP address it will be: 

on Action(parameter) 
  tell application "OnTheAir Video" 
    switch videohub ip_address "192.168.0.70" output_index 1 input_index 
1 directly 1 
  end tell 
end Action 
 

https://www.softron.tv/products/ontheair-switch#tech-specs-system-requirements
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Note that the "directly 1" instruction at the end of the line allows you to set wether the 
communication to the Videohub will require Bonjour or not. When setting it to 0, we will scan 
through the available Videohubs that we find in Bonjour, and find the one with the matching 
IP address. While when setting it to 1, we don't use Bonjour, and just connect to that IP 
address. With the name: 

on Action(parameter) 
  tell application "OnTheAir Video" 
    switch videohub name "Studio Videohub 12" output_index 1 input_index 
1 
  end tell 
end Action 

And with the unique ID: 

on Action(parameter) 
  tell application "OnTheAir Video" 
    switch videohub unique_id "8371c4cc399b" output_index 1 input_index 1 
  end tell 
end Action 

	 	 	 13.10.3.2. Using the Set Selected Input Method  

Here is an example of script that can be used to control a Videohub. If you only have one 
Videohub, you could use: 

on Action(parameter) 
  tell application "OnTheAir Video" 
    tell (first videohub device) 
      set selected source of destination 3 to 4 
    end tell 
  end tell 
end Action 

There is nothing to do in OnTheAir Video as it will automatically scan the network to 
discover a Videohub through Bonjour. So in the example above, we will search for the first 
available Videohub and use it. 
You could change the script to only use a Videohub with a specific IP address. 

on Action(parameter) 
  tell application "OnTheAir Video" 
    tell (first videohub device whose ip_address is "192.168.0.70") 
      set selected source of destination 3 to 4 
    end tell 
  end tell 
end Action 
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Or using its name: 

on Action(parameter) 
   tell application "OnTheAir Video" 
     tell (first videohub device whose name is "Studio Videohub") 
       set selected source of destination 3 to 4 
     end tell 
   end tell 
end Action 

13.10.4. With Ross  

With Ross, there are two different protocols available, depending on what your router 
supports. 

• RossTalk is the most widely compatible one. But there is a caveat with it: we can't 
receive the information wether the switch was done or not, so we just send it out and 
have no knowledge if it was received or not and wether the switch happened. 

• ProBel (or "SWP-08") is compatible only on some routers, check with Ross to know if 
your router supports it. The advantage is that if there is an issue to send the command 
or that the switch did not happen, we will receive a notification and add a log. 

	 	 	 13.10.4.1. Using the RossTalk Protocol (OTAV 4 or later) 

You just need to indicate the IP address of the Ross video router. And then specify which 
"command" (which GPI) you want it to execute. Check your Ross manual to know how to 
modify those GPI. 

on Action(parameter) 
    tell application "OnTheAir Video" 
        switch rosstalk ip_address "127.0.0.1" command "GPI 04" 
    end tell 
end Action 

	 13.10.4.2. Using the ProBel Protocol (OTAV 4.1 or later) 

You just need to indicate the IP address of the Ross video router. And then specify: 

• the matrix and level to use 

• the source and destination 

tell application "OnTheAir Video" 
    switch probel ip_address "97.78.209.190" matrix 1 level 1 destination 
1 source 7 
end tell 

If you are looking for sample actions, go to the website version of this chapter. We will find 
links at the end of it.  

 

https://softron.zendesk.com/hc/en-us/articles/360016418240-HOW-TO-Control-a-video-router-with-OnTheAir-Video
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13.11. Control with MIDI  

One of the lesser known features in OnTheAir Video is the MIDI control feature. OnTheAir 
Video’s MIDI Control allows you to assign a MIDI note to buttons and clips. 

MIDI devices are automatically detected when attached to a system, you only need to plug 
in the device and you can use the feature immediately. The simplest way to test this feature 
is to start with a simple MIDI keyboard. M-Audio, Roland and a variety of manufacturers have 
USB keyboards that are both inexpensive and packed with options. Once the MIDI keyboard 
is attached to the computer, open OnTheAir Video.  
Then go to the MIDI Settings of  OnTheAir Video. You can set: 

• The MIDI input device: the device that you 
use to control OnTheAir Video. It will send 
MIDI triggers to OnTheAir Video and 
OnTheAir Video will play, stop clips when it 
receives these triggers. 

• The MIDI output device: the device to which 
OnTheAir Video will output a MIDI note when 
specific clip will start playing. 

13.11.1.  Control Playback with MIDI 

Assign a MIDI Control to a button:  
You can assign a MIDI note to a button if you want to control the 
generic playback control such as play, pause, or even put a 
playlist in loop. For that, right-click on any button and select 
"Assign MIDI Control..." 

Assign a MIDI Message to a clip:  
Instead of assigning to a button, you can assign a MIDI Message 
to a clip directly, so you will control the playback of that specific clip. For that, right Click on a 
clip and select: 
• "Assign MIDI Input Message…”: Then simply hit a 

key on your MIDI device (make sure to have only 
unique notes for each clip, otherwise you won't 
know which one will start). You can also set it 
manually. A list of preset messages is also 
available. That's it. Now if you press again that MIDI 
note, the clip will start playing, and continue with the standard behavior of the playlist (if it's 
in chain, it will continue playing the next clip, or stop at the end if it's not in chain,…) 

• “Assign MIDI output Message…”: You can automatically output a MIDI note when a 
specific clip starts playing, that way you can control external devices with MIDI. Then enter 
manually a value for the Channel and Note. That's it, the next time the clip will play 
OnTheAir Video will output that note to the MIDI device selected in the settings.  

To clear a MIDI note, right click on the clip or button and select "Clear MIDI Note". This will 
clear both the input and output MIDI notes. More information on our website article. 

 

https://softron.zendesk.com/hc/en-us/articles/207696557-HOW-TO-Control-OnTheAir-Video-Express-with-MIDI#:~:text=For%20this,%20right%20click%20on,device%20selected%20in%20the%20preferences.
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14. Traffic Option 
Not available in OnTheAir Video Express. 

The OnTheAir Video 4 traffic option brings a host of features. Here are some of the features 
that it brings: 

• Wide Orbit integration: open Wide Orbit (WOS) playlists 

• Media Browser: add support for a local or remote media browser 

• BXF: add support for BXF files to automatically create "segments" in the Media 
Browser 

• Folder-based schedule: create one playlist per day, and simply place it in a folder 
using the appropriate name 

• Remote Control: allow to control or monitor OnTheAir Video remotely, with also the 
ability to do "gang playback control" 

• "Virtual" sources: Which are live sources with some preset attributes (actions, GPI 
trigger, etc...) 

• Process purge lists: import .DAT files to know which clips should be deleted from disk 

This option is made for an extensive use of the scheduler and the playlist system, using 
Wide Orbit integration. We will not go further in this User Manual, which is designed to 
introduce you to the basics of OnTheAir Video 4.  

If you are looking for more information, you can find links to: 

• Our website article “About the "Traffic" option of OnTheAir Video 4”  

• Our Youtube video “OnTheAir Video - Traffic Integrations” 

• Our Youtube Video “Master Control with OnTheAir Video Traffic Option” 

 

https://store.softron.tv/product_info.php?cPath=45_27&products_id=230
https://softron.zendesk.com/hc/en-us/articles/360016086900-About-the-Traffic-option-of-OnTheAir-Video-4
https://www.youtube.com/watch?v=h-2rmvDX7qE&ab_channel=SoftronMediaServices
https://www.youtube.com/watch?v=iNScJRYMrtg&ab_channel=SoftronMediaServices
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15. EPG Option 
Not available in OnTheAir Video Express. (The EPG option is available in our website store)  

This option allows you to add the support for EPG (Electronic Program Guide) to a OnTheAir 
Video license. A useful tool to determine the list of current and scheduled programs, with 
information and details for each program on your channel. On each clip you can add info 
such as a title, category, etc… You can then export that info into an XML file. 

15.1. EPG Window 

To open this window, go to the top menu “Window > EPG Tags”. You will find three panels: 

15.1.1.  EPG Tags 
It is where you can create a new EPG tag and set information about a program:  

• Unique ID: A unique identifier set to your EPG tag when you create it.  
• Air Date: Information about when the program is scheduled to be played. 
• Last Modification: Is set each time changes are done to the Tag. 
• Modified By: The ID of the last person that modified the Tag.  
• Title: The name you give to the Tag.  
• Sub Title: A secondary or explanatory title. 
• Synopsis: A short description of the contents of the program.  
• Season/EpisodeNr/EpisodeID: Set information related to a TV show or a TV series. 
• Rating System: The TV Parental Guideline, different between countries. You can set the 

info between V-Chip, MPAA or Other (it will not affect the OnTheAir Video playout). 
• Rating Value: A value related to your Rating System (PG-13 in the USA for example). You 

can create presets through the Ratings Window.  
• Categories: The category of your program (Movie, Sport, News…). You can create presets 

through the Categories Window. 
• Icon URL: to add an Icon to your program.  
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15.1.2.  EPG Categories 
 
You can set multiple Category Name for your programs: 
• Just click on New Category to add a new one. 

Double-click to edit one you already added and 
press on the Trash to delete it.  

• You can add as many Category Names as you want. 
Click on Search to find one with the name you are 
looking for.  

• On The EPG Tags window, when you set the 
Categories, a small window will appear with the 
Category names you created. It saves time when 
you create a new EPG Tag. 

 

15.1.3.  EPG Ratings 

Same logic with the EPG Ratings Window, you can 
preset Rating Names to save time when you create an 
EPG Tag.  
• You can add a new Rating name. Double-click to edit 

it or the Trash to delete it.  
• You can add as many Rating Name as you want.  

15.2. Add/Remove an EPG Tag to a Clip 

• Just drag and drop the tag to the clip in the 
playlist. When it is done, you will see an EPG 
logo added to the clip in the playlist.  

• If you want to remove an EPG tag from a clip, 
open the contextual menu with the right click 
and “EPG > Clear EPG Tag from Selected Clips” 

• If you click on “EPG > Show EPG Tag”, it will open the EPG window. 

15.3. Export EPG 

To export EPG, go to the top menu “File > Export EPG…”. 
You can choose between a XML or a TV guide file. OnTheAir Video will automatically detect 
all the EPG tags and their information in the clips from a 24 hours schedule.  
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16. List of Keyboard Shortcuts  
Note: On some keyboards "option" is indicated as “alt”, “Command” is indicated as “cmd” 
and “control” is indicated as “ctrl”.  

Keystroke Action
File

command + n New Playlist

⇧ + command + n New Folder-Based Playlist

command + o Open Playlist…

command + r Check for Missing Clips

option + command + r Validation Report…

command + w Close Window

command + s Save Playlist…

⇧ + command + s Duplicate

Add

option + ⇧ + a Media Files…

option + command + a Clip by ID…

option + ⇧ + l Live Clip…

option + ⇧ + o Offline Clip…

option + ⇧ + c Comment

Window

command + i Clip Inspector

⇧ + command + p Output Preview

⇧ + command + l Activity & Logs

⇧ + command + y Stream Deck

⇧ + command + m Media Browser

⇧ + command + v Virtual Sources

⇧ + command + t Transition Editor

command + t New Timing Window

Document Edition / Navigation

command + z Undo

Keystroke
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⇧ + command + z Redo

command + x Cut

command + c Copy

command + v Paste

command + d Duplicate

command + a Select All

command + p Now Playing

option + command + p Go To Play Next

⇧ + command + r Randomize Playlist

⇧ + command + j Join in progress

command + f Find…

command + g Find Next 

⇧ + command + g Find Previous

option + command + up Select First Clip in playlist

option + command + down Select Last Clip in playlist

up Select Previous Clip

down Select Next Clip

option + C Set Chain mode on/of

option + L Set Loop mode on/of

option + Q Sert Cue Mode on/of

option + K Set Key mode on/of

Scheduling

command + ⇧ + o Open Schedule

command + r Reload the current schedule

control + command + s Show the Schedule Window

option + command + s Save Schedule

Playback control in Playlist

⇧ + left Go 1 second earlier

⇧ + right Go 1 second later

⇧ + ctrl + left Step backwards

ActionKeystroke
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⇧ + ctrl + right Step forward

k Pause

s Stop

option + left Skip to previous

option + right Skip to next

option + command + left Go to 5 seconds before the end of the previous 
clip

option + command + right Go to 5 seconds before the end of the current 
clip

space bar Toggle play/pause playing clip

option + space bar Force play selected clip

Playback Control in Inspector

left Go 1 frame earlier

right Go 1 frame later

⇧ + left Go 1 second earlier

⇧ + right Go 1 second later

option + left Go to end of clip

option + right Go to beginning of clip

space bar Play/stop/pause

Clip Edition in Inspector

i Set in point

o Set out point

⇧ +  i Go to in point

⇧ + o Go to out point

option + i Clear in point

option + o Clear out point

option + x Clear in and out points

ActionKeystroke
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17. When Something Goes Wrong… 

While we strive to ensure that OnTheAir Video be as stable a platform as is humanly 
possible, there is a lot of interaction between our software and other pieces of your 
workflow (your MacOS, video card drivers, switchers, etc.), and so we must constantly evolve 
our product to adapt to changes made in those applications. As such, bugs do sometimes 
sneak up on us. Should any issues arise while utilizing OnTheAir Video the first place to look 
for answers to potential causes is our white pages on our Softron Support Desk website. 

Keeping an eye on the Performance Gauges in the Activity & Logs window (accessed via 
“Window > Show Activity & Logs Window”) is also a valuable resource. 
The Performance Gauges show the performance of your computer as it runs the application, 
and may prove a useful indicator as to what could be causing issues. See our 
Troubleshooting: The Log Window Explained article for details. 

And also keep in mind that for the life of the product, your application includes our support 
service. The best way to reach us is via “Help>Contact Support” in the user interface of the 
application (see below for image). Through that button you can collect the technical logs 
from the application and open a support ticket on our Support Desk. It is important that 
when opening a ticket that you supply as much information as possible, including the date 
and time of the incident(s).   

 

https://softron.zendesk.com/hc/en-us
https://softron.zendesk.com/hc/en-us/articles/207695067-TROUBLESHOOTING-The-Log-window-explained
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